Serious equalization curve bug

(I’m using Audacity 2.1.2 in Windows 10 Professional)

I’ve depended on Audacity’s equalization curve facility for years, to compensate for the furry windshield muffling that affects all my sound recordings (natural soundscapes), together with compensating for my current recorder model’s weakness on the very low frequencies. I did find that Audacity is buggy in that if I create a curve in the EQCurves.xml file, and it gives values for below 20Hz or above 20KHz, it refuses to recognise the curve, dumping me on ‘Unnamed’ instead. But I have got round that by not using Audacity’s UI at all for creating / configuring those particular curves, and specifying them directly in the command chain configuration files, again keeping the Audacity UI right out of it. Like that the curves would be applied to the full and worked perfectly.

Now, however, I’ve hit upon a really serious, show-stopper Audacity bug concerning EQ curves. I’ve started trialling a new and somewhat more resistant combination of windshields for my insanely wind-sensitive sound recorder (Sony PCM-D100, for which any single windshield is woefully inadequate), and so had to work out a new EQ curve. Unfortunately for the type of windshield I’m using as the ‘inner’ I have to create new curve for each recording session on each recorder, so this is huge work for me, but at least I can do it - except that now for some reason Audacity is completely corrupting the curve and so I’m stymied. The corruption is not only in the UI display as shown in the two attached files, but is actually applied when I apply the curve, even when using a command chain set up without involving the UI.

I seriously need a better program, which is non-buggy in handling detailed, high-resolution EQ curves, for at the moment Audacity is a complete dead loss for me now if I am to use more wind-resistant windshield combinations. Is there any prospect of this being fixed at all soon?
Audacity EQ bug.gif
EQCurves.xml (626 Bytes)

The Manual does refer to those limitations.

All versions of Audacity I tried read incorrectly after the first three points. I tried doing without the “/” in the curve name, just in case.

So to be clear, are you hand crafting that attached XML file outside Audacity, or creating it in the UI? If in the UI, in Draw Curves? In Linear or Log scale?


Actually the questions are answered in my original post. And the screen clip shows that Logarithmic display is ‘on’ (i.e., ‘linear’ is unchecked) - not that that is relevant to the issue I’ve described.

As for reading incorrectly after the first three points, that has never happened for me before, so I’m bewildered that something like that is happening now, seeing that I haven’t changed anything relevant in the meantime. Until now Audacity had been doing me a great job with my detailed EQ curves, as long as I put them into the EQCurves.xml file and didn’t use the Audacity UI at all for the purpose. Sadly, I guess I shall have to abandon the more wind-resistant windshield combination simply because I cannot do the requisite EQ for it, whereas the EQ works for the combination I was using previously.


Sorry, but I don’t agree. You could have hand-crafted the curve and then imported it to show us the UI. And what you wrote in your last post still implies you are hand-crafting the curve.

Would you like to clarify now for us?


Well, well, well! So, not only I but nobody else either noticed! :slight_smile:

Look at the EQCurves.xml carefully and you’d see that I’d made an error in not increasing the number of digits before the decimal point for frequencies from 10KHz! Correcting that solves the problem! Great sigh of relief, and I hope this topic will serve as a useful prompt for anyone else who falls into the same little trap! :slight_smile:


I just got confused because you did not have the points listed in ascending frequency order - the curve does actually read correctly as you wrote it.

But you’ve proved that you can list the points in random order, so that is one learning point.


What “trap” is that? The curve shown in your first post appears to match the data that you entered in your XML file - what am I missing ? :confused: