Self mixing and rendering

Hello, I am running mic and guitar into an Alesis multimix4 and then into laptop via usb and finally into Audacity…problem is that as I overdub the tracks are NOT remaining separate…
Example: first track is guitar and vocals
Second track is lead guitar solos ( while listening to 1st track in headphones ). When I playback only second track (with first track muted) I hear both tracks just like when they are mixed and rendered.
Here’s the twist…if I make the exact same recording using only the laptop internal microphone the tracks remain separate during playback and I am able to tweet each track prior to rendering them. I am hoping someone has run into this before…maybe there is a setting that I need to change. I called Alesis and they say it cannot be from the mixer

Yes it can. The mixer has a EXT/USB TO MAIN button which will feed the Audacity overdub guide track into the mixed show. That should not be pushed.

Audacity > Preferences > Recording: [_] playthrough (de-select)

The other options are peculiar to Linux. The settings for self recording or recording YouTube are wrong for overdubbing. I don’t know what those are. I’m a Mac elf.


Thanks, not pushing the Ext/usb button worked…the tracks are now staying separate but I have no audio through headphones unless I push the button in. So, it seems that I need to have button UP while recording and DEPRESSED when playing tracks back or else I cannot hear anything.

I have no audio through headphones unless I push the button in.

You need to be really, really accurate when you post your observations. You can’t hear yourself performing when the button is up?

Audacity > Preferences > Recording: [X] Overdub…

Is that selected?

Since the mixer “knows” how to mix Audacity existing sound into the show for recording, I expect there to be a setting that allows you to hear without the old tracks being remixed into the show. It’s like why on earth would you have one without the other?

Mess with the FX knob right above the USB button.

Or, if you get right to the end of your rope and just can’t go on any more, read the instructions.


I was not specific…sorry. I CAN hear myself and all previous tracks of the project while performing with the usb button in the up position, but I CANNOT hear anything during the playback mode unless I press in the usb button…so that button is going to get quite a workout unless there is another way around it.
As far as the preferences selections, can u please tell me again how they should be? Play through? Overdub? Maybe a screenshot?
The instructions are so non specific, and I spoke with the company and they had no knowledge of this problem before
Thank you

Software playthrough off and Overdub on. These are default settings as shown in the Audacity Manual:


thanks Gale,
i am recording in mono so i’m not sure if i should uncheck the playthrogh box or not. Still, the issue is that i have to release the “ext/usb to main” button when recording and depress it the button in order to hear the playback…there doesn’t seem to be a way to work around that.

I just recorded guitar/vocal track with Ext/usb button in UP position, but when I went to record the 2nd track I could not hear the first track. I tried button in both positions. Also tried preferences in both settings…checked and in checked but still cannot hear first track
Thank you

In Audacity, enabling Overdub plays already existing unmuted tracks while recording. If Overdub is off, existing tracks are not played while recording.

Software Playthrough in Audacity plays what you are recording through the output, after a delay. Software Playthough should be off, because you should be able to monitor your recording without any latency by using the headphones port on the mixer.

Audacity has no control over buttons in hardware mixers.


Gale, it seems like most of my problems are solved with the proper preference settings and by plugging headphones into computer instead of the mixer. Problem is that now I cannot hear the track I am currently playing through the headphones but I can hear all playback tracks

HELP PLEASE…SOMEONE MUST HAVE AN ALESIS MULTIMIX4 fx usb that also uses Audacity with Linux mint…so frustrating…here is what happens when I record.
First track…must have headphones plugged into mixer or else I cannot hear.
Small usb button can either be up or down…no effect
Second track…if I leave the usb button in the down position while overdubbing the first track gets pulled into the mix, so I must overdub with button raised. But, now I can no longer hear through the headphones so I must switch headphones to the laptop input and change the setting in Audacity to “default” in order to hear the first track. Now, I can overdub, BUT I cannot hear the overdub track through headphones…I am now only hearing the first track through headphones.

Preference settings for record are overdub is checked, Software play through is not checked
Latency 100 and -130. Sound activated is not checked

Thank you, steve

I’ve been trying to get the User Manual for this mixer. So far, nothing doing. Alesis is happy to send me the Quick Start Guide. That’s no help. I need the detailed instructions how to set the mixer controls. Their text instructions seem to tell me what you want should work.

Alesys has their own user forum.

Chances of finding someone with that mixer on Linux Audacity Forum is very close to zero.


Thanks for the Alesis link…I will try that

Here is a link to the Alesis topic Enginecap started

If you now have your headphones plugged into the computer and Audacity playback device set to the computer (default) then you will need to enable Software Playthrough in Audacity to hear yourself recording the overdub. But you won’t like the latency.

It is possible this may only work if you take an analogue line out of the mixer. Does your laptop have a line-level input or (much more likely) only a mic input?


Thanks gale,
I am not sure how to know whether or not I have a line level input…like you said , more than likely it’s a mic only laptop. Here is something new…when overdubbing, the recording will just stop on its own.
I thought I had a good thing going with the Alesis and Audacity until a friend pointed out that my tracks were not separate (each track was being pulled into the mix)…now since trying to solve that it’s been one issue after another

That happens when you’ve got a region selected in another track.
Press the left arrow key once to deselect (while preserving the cursor position).


Pavucontrol if you have it installed will probably show you, or you can just try it at a very low input level and see if you get stereo or mono. However if it is stereo it is not going to be as high quality as the USB input.