Selection Toolbar in Audacity 2.2.0

What I have found is that before version 2.2.0, after opening a audacity file you could go into the time selection at the bottom of the window, enter the selection range (which would automatically select that range), and either copy or export the selection. What I am now finding is that you must first select a range, change the range to what you really want, then you can copy or export the selection.
Any way this could be incorporated into a future release?

I split your post from the topic where you posted as it looks like a different issue.

The time controls have changed in Audacity 2.2.0. In particular, the order of the boxes has changed, and there are additional options for what they show. Full details are in the manual, here:

Previously to the latest update (2.2.0) there was an option to Export selected which was great for what I would do, but it seems that as been replaced with “Save other” then “Export MP3”. This is good if you wanted to save the whole project as an MP3, but I just want to select part of it (using what is entered in the “Start and End Selection”), and “Export as MP3”. “Save other” just seems to only save everything.
With the way it is now I have to open the project, select the desired section, copy that to a new project, then save other as MP3, then just delete that project because I do not need it.

Any help will be greatly appreciated.

I’ve tried the Audacity 2.2.1 RC1 and I thank you for adding the Export and I do want to report it works just as I have requested. I must apologize as looking back at 2.2.0 I noticed within “Save Other” there was a “Export Selected Audio…” which I am not sure I did see before.

I thank those who worked on the changing of “Save Other” to “Export”.

For new questions, please start new topics. It quickly becomes confusing if the forum thread jumps around from one subject to another.

In Audacity 2.2.0 it is:
“File > Save Other > Export Selected Audio…”

In Audacity 2.2.1 it will be:
“File > Export > Export Selected Audio…”

You’re welcome :wink: