Selection Tool not working

I’m not sure what is going on. I successfully imported a recording I made (using a Zoom H1). It’s only spoken word 1 track. It’s not a mp3 but a WAV. Does this make a difference in the ability to edit? (I know the quality if supposed to be much higher, and that’s the suggestion in recording on the Zoom).

I’ve been trying to edit it, and tighten up where there is too much space, mistakes, etc. The selection tool is not working. If I can get it to select anything in the track, no matter how zoomed in I am, it’s just make a line where I’ve clicked, but it won’t select where I move my mouse (holding down the right button - or with a track pad).
Once in a while it will allow me to make a selection, but it will only select 1 second of time. The only way I was able to delete that section was to zoom up wide so that selection would actually only be a fraction of a second. There’s a little triangle in the bar where it shows what second I’m at - and it can be pulled in either direction - but that doesn’t extend the selection.

When I had previously worked on a project that I recorded using audacity, the selection tool works. I LOVED how it would join the regions that had been separated by the delete. What could be wrong? I tried changing from stereo to a mono… In fact, I went back to that recording, and when I first tried it, it WOULD - but NOW it stopped! Talk about frustration!

It’s probably a good idea to read the FAQ’s. This one: Why can’t I select less than one second or click between whole seconds?