Selection too long for analysis by ACX check..but this never happened before

Audacity Version 2.3.2
Mac High Sierra 10.13.6

"Selection too long for analysis, please select shorter section
Length of selection: 2316.27 seconds.
102147584 samples at 44100Hz. "

Is the message I’m getting.

I’ve been using the old version of Audacity a couple of years to narrate short books- under 3 hours.
A couple weeks ago I completed one (40 minutes or so) and ACX check worked great.
This week a 38 minute selection is suddenly too long.
I updated my Audacity version yesterday, I’ve installed and enabled my ACX check plug in at the same time but I am still getting this absurd error message that the selection is too long. I’ve used ACX check to check much longer selections in the past.

PLEASE help. Does anyone have any ideas??

ACX-Check has a hard coded limit of 100,000,000 samples.
If your track is longer than that, you can select part of the track, analyze it, then select another part and analyze that.
To select part of a track, see: https://manual.audacityteam.org/man/audacity_selection.html

Ok,
but why has it worked for me all these years and only now am I getting this message?

Do you mean eternally I can only check a million samples and I’ve used that allotment up?

Perhaps you were selecting less than 100,000,000 samples?
Perhaps you were using a different plug-in?

One thing I can be sure of is that this version of ACX-Check is limited to 100,000,000 samples.

I mean that the plug-in will process a maximum of 100 million samples at one time.

The code sets “max-len” to 100,000,000

(setq max-len 100000000)

Then when you run the effect, it tests that the length of the selection (“len”) is not greater than “max-len”

(if (> len max-len)
    (format nil "Selection too long for analysis, please select shorter section~%")

Did you change the work? If you decided to produce in stereo (two tracks) instead of mono, the size of the show will have doubled.

You can work in 48000 sample rate instead of the more common 44100. That will throw everything off.

Did you nudge the PAN control (L…R) to the left of the timeline by accident?


Screen Shot 2019-07-07 at 14.34.27.png

The L…R adjustment in the illustration is not in the middle. It’s 10% to the right and the show is now twice a large as you think it is.

Koz

First
Thank you for taking the time to help me with this


Oh, perhaps maybe I did do that with the nudge. I’ll go in and check when I get home again.

I’m afraid maybe that I’m not sure what a sample actually is. I see the message states I’ve selected over 100million bt I guess I’m confused as to what actually is. I assumed the sample was my recording.

Unlike “analog audio”, which is a continuously varying signal, “digital audio” is a series of numbers, each of which represents the amplitude at a given point in time. Each of these numbers is a “sample value”, and typically they are spaced out at intervals of 1/44100th of a second (so there are 44100 samples per second).

If you zoom in very close on a waveform (Zooming Overview - Audacity Manual), you will see that the waveform eventually becomes a series of dots. Each dot represents one “sample”.


Thank you both for this assistance I’m going bald pulling my hair out.

Let’s say, I did nudge the L-R, does that mean that I cannot correct it now and I need to re- record my narration? And if that’s the case so be it, I will.

I’m trying to analyze in sections but this is too rough. I don’t earn enough doing this to suffer this hard :laughing:

That will double the size of the project, but it is not relevant to the error message. ACX-Check is limited to a length (duration) of 100m samples, (not a “size”).

If you nudged the L-R “Pan” control, it is correctable.

Did you save the project as well as exporting an audio file? What format did you save / export (including backup copies)?

I have saved it as .aud but have only exported the first 15"
The piece I am trying to analyze is the saved project.
My mind is blown by this because I’m doing everything exactly the same as I’ve been doing for two years.