"Seeing" my USB mike

Using Audacity 2.3.3 on my Windows 10 for book recording, with USB plug in of my RODE mike. A long standing problem: Often Audacity will not see/recognize the USB mike. After many attempts (plugging and removing, 10, 20, 30 times) it will finally do so. Using the Transport-Rescan does not help. (Have updated driver. Have uninstalled and reinstalled Audacity)
(A second problem I will mention, in case it is related: Often the Recording function will freeze. All other functions will operate. It is in trying to unfreeze (turning computer off and on) it that I lose the USB Mike recognition.

At first pass, we would normally go for the microphone permissions solutions, but if you plug and unplug multiple times and it eventually succeeds, you have a broken USB connection. Also see: stops dead in the middle of a recording.

Do you have pets? Take a flashlight to your female USB connection and check for hairs or dirt.

Does your machine have more than one connection? Try different ones. Are you trying to record through an adapter or USB hub? That can cause problems.

A more out-there possibility for a laptop, does the problem change if you run batteries or wall power? Does the laptop run on batteries at all?

Forget Audacity for a minute. Does the microphone show up in Windows Control Panels - Sound. It has to appear there first. Right-click the speaker symbol in the lower right.


I sincerely appreciate the advice. Apparently, changing to the battery works. It has worked three times now. Nothing else seems to do so. I have two USB ports. My printer works in either, so that is not the problem. My setup would, I think, be considered the “adapter or USB hub” you mention as being a problem. May try to rework that—but in the meantime, your advice regarding the battery seems to work.

Wow! It seems to work every time (connecting the USB mic while using battery). It has 7 times straight. (The reason I haven’t quickly tried 25 or 50 times is that I fear losing the recognition—and so I wait until it does so (why, I don’t know.) How strange–but it seems to work. Thanks.