searching for an answer

I’ve got an HP Pavillion m8000 with an onboard audio card, I believe it’s a Realtek. I had a 5.1 logitech speaker setup hooked up to it, and I was able to record what I heard with no problem. Recently I upgraded my sound system using a Yamaha RX-V373 with Martin Logan speakers, and connected the Digital output of my sound card to the Digital input of my Yamaha RX-V373. Needless to say, the sound quality and power it throws off is amazing!

However, now I can’t record what I hear anymore. I’ve tinkered with settings and searched the internet and can’t seem to figure it out. I have “stero mix” enabled correctly, yet still no ability to record any audio from my computer. Could it be as simple as connecting a, audio out cable (RCA) from my receiver back to the soundcard on my computer? I’m thinking the audio from the digital out to the receiver is bypassing the Audacity program on my computer.

I’m stumped hear and would really appreciate help from anyone who has a similar setup, and the problem I’m having.

Thanks everyone, I hope to hear back from someone soon.

Oh, btw, I don’t know if it matters but my OS is Vista Ultimate 64bit

Thanks for the complete information.

Self Recording is a delicate balance between Software, Drivers, Hardware and Operating System. Self Recording is also not a guaranteed service, so nobody pays a lot of attention to it. You may have hit a combination that just doesn’t work.

Audacity will record and play using whatever the computer provides. If the sound pathways aren’t there, that’s the end of the story.

Yes, you can do the hardware cable loopback trick, but that sends the sound through digital conversions three times and it gets slightly ratty each trip.

Google your equipment and see if this isn’t a known problem.

“Oh, sure. To get that you have to download this special driver…”


With the Realtek drivers, “Stereo Mix” is often coupled tightly to the analog front speaker output (the green jack) of the on-board sound chip.
For example, many systems with dedicated headphone jacks mute Stereo Mix when you plug the headphones in since that silences the speakers.
Chances are that your Stereo Mix is working correctly, as designed, faithfully recording what is sent to the analog front speakers, namely nothing.
If I understand correctly you have routed sound to (2), yes?
Problem is that “Stereo Mix” is still listening to (9).

A cable from your receiver to the blue line in (8) should work, but as Koz mentions, there will be a couple of extra conversions between analog and digital.


I know you’re thinking to yourself: “Self (you’re thinking) how bad could a couple of conversions be?”

It’s three, not two and you can have overload, clipping, noise floor, distortion, and gain change problems at each conversion. In other words, you gather all the bad features of each format.

What could go wrong?


I have to both apologize to all of you who responded to posting, and commend you all for your input and advice. The apology is, for some reason I didn’t get notifications of your responses, why I’m not certain, and I reposted yesterday and someone referenced my original posting for help.

So, a few thoughts. I still have the original Logitech 5.1 speaker system (eventually going on Ebay) so I could just reconnect them and adjust, or redirect in realtek settings and disable the digital audio out, reverting back to my original setup, bypassing all the conversions mentioned in your responses.

Or, I do have an audio out on my receiver, appears to be just stereo (red and black RCA type plugs), reconnect to green (and blue?) plugins on my sound card? Am I on some kind of track here, or completely off? The signal on audio out of my receiver would be digital, so I’m thinking the multiple conversion problem may come into play. Ugh, I’m so frustrated.

Thanks again all, please review this post and get back to me with your expert advice and input, I really need it. I’m hoping to get this resolved today, the 12-12-12 concert on tonight would be a nice capture.

Yes, it would, but that does work. You need a cable like this.

…and that should go into the blue connection of your sound card. That’s almost always stereo Line-In. Then tell Audacity to record from Stereo Line-In and set volume levels. You can right-click on the red record meters and select Start Monitoring. They will wake up and meter the sound without you having to go into full record.

Radio shows tend to be very well behaved for variations in volume because for them, it’s a legal thing.

The step by steps in Windows are beyond me, especially if you have a talented music system on the computer.

I do a very similar job on a weekly radio show.