screen goes dark and computer unresponsive

Hi. I just upgraded my macbook pro to El Capitan OS X 11.4 and Audacity 2.1.2.

I capture Recording for the Blind talking books using Audacity to convert them to mp3 formats to carry them on my MP3 player. The captures run several hours. I set up the recordings and then let the computer and the talking book machine run and check it periodically to see if things are still working ok. The talking book machine is connected to a sound blaster pro USB sound card.

This is the first time I ran the setup with El Capitan, and about 6 hours into the recording, I checked to see if things were running properly. I tried bring the screen back to life by tapping a key but all I could see was a spot in the upper left corner of the screen and the cursor. I tried tapping other keys but nothing happened. I could hear the recording through the ear phones that recording still appeared to be progressing. So I decided to check it in the morning when the recording was scheduled to be finished.

In the morning, there was no sound coming the the earphones and when I tapped the space bar to stop the recording, screen fragments appeared with backwards upside down writing. I shut off the computer and restarted it. Audacity tried to recover the file but gave an error message that inconsistencies were found. I check the computer for malware but didn’t find anything significant. This is the first time this has happened in 7 years of using Audacity

El Capitan is very concerned about saving power. I would check the power settings so there is no risk the computer will try to sleep or turn off the screen during a recording.

Also, right-click or CTRL-click, and choose “Get Info”. Then put a check (tick) in “Prevent App Nap”.

Unfortunately if you don’t first save an Audacity project, then shut down the computer, the Mac will delete your Audacity temporary files when it restarts and your work will not be recoverable. I hope the next release of Audacity will move the Audacity temporary directory on Mac to a location that is preserved after reboot.


This is the first time this has happened in 7 years of using Audacity

And the first time you tried using El Capitan.

What did you upgrade from? Has this been a continuously updated machine, or did you burn it off, hose it down and start over?

If you used to be in Mavericks (10.9), what’s the possibility of rolling the machine back to that, just as a test? You keep religious Time Machine backups, right?


Time Machine doesn’t back up the default Audacity temporary directory (/private/var/folders). That’s another reason why I want the Audacity temporary directory changed.


This is a known problem with EC. There’s no fix yet. It doesn’t occur for everyone.

As Gale said, try setting your power settings to “always on” in system prefs.

Also, select Audacity’s icon in /Programs and do “Get info” from the File menu in the Finder. Disable “App nap”.

If this doesn’t help, you could try AntiPop:

That should keep your Mac’s audio system awake.