Scratching/buffering on imported track

So I’ve got a problem, but I don’t really know what problem I have. I’m trying to record a song using: an instrumental I produced in GarageBand, my Behringer C-1 microphone and Audacity. I have a Toshiba laptop running Windows 8. I set everything up and it appears to work just fine except when I try to record my voice the track buffers and scratches in my headphones. Then when I play it back my voice buffers too. I don’t know if it’s in the same place every time; sometimes the buffer will be in one place and sometimes it comes and goes. I tried to fix the problem myself to no avail. First I thought it was Audacity, so I tried to record in another program called Reaper, but the problem stayed (and perhaps it even got worse). Then I thought that it might be the mic or the headphones, so I unplugged both from my computer and just used the built in two-way speakers. I still have the problem. I’ve restarted my laptop several times and I uninstalled and reinstalled both programs. I just don’t know what my problem is and I was hoping someone could save me the googling. Thanks :mrgreen:

the track buffers and scratches in my headphones.

Say that again without the word “buffer.” Or post a sample of the damaged work. Or both.