saving project as.... file

while trying to save project as… i get error saving project… could not save project.perhaps[file name]is not writable or the dick is full. the disk is not full. What would keep the file from being writable? I’m new to audacity and not an expert when it comes to computers. I’m using win 7and used an exe. installer

Using invalid characters in the file name, such as punctuation marks or slashes.
Try using only letters, numbers, spaces, hyphen (-), underscore (_) in the file name.

thats all i’m using. the file name is, 2012-04-05 Ed Cowger_bitterness, is their anything wrong with this? It was working fine before with this format i was able to save two pervious files that way now i can’t.

Are you trying to overwrite an existing file?
What format are you trying to use?
How much free disk space?
How long is the recording?
What is the exact location that you are trying to save to.
Which version of Audacity are you using? (look in the Help menu > About Audacity)

It’s really poor practice to constantly overwrite one single file as you edit. You can get days into the production and have the lights go out, the computer glitch, or any of a million other problems and that’s the end of the show. The original shoot and all the editing are gone. No going back to yesterday’s version or the edit you did last week.

People complain that they’re just editing a little thing for school and it doesn’t matter. The problem is you carry that habit with you into bigger productions where it matters a great deal. Koz

One further possible source of the problem: what, if any, metadata do you have associated with that file?

no I’m not trying to overwhite an existing file, not sure about the format just trying to save an original recording, i’m saving to an expansion drive that has 1.8 terabytes, the recording is about 40 to 45 minutes, the exact location I’m trying to save to is a file i created in the expansion drive (G) labeled church services, I’m using version 2. I was able to save the first two recordings i did. then i converted them to mp3 and deleted the orginal files. After i did that is when i started having this issue. it has happen twice

not sure about the metadata associated with the file

Just so I understand this…

You have three sermons from different days. You opened the first one and edited it for sneezing, pauses and other errors and saved it as an Audacity Project and then exported it as an MP3, we assume for the enjoyment of the parishioners.
Then you deleted the original capture file.

You did it to the second one, too, but the third one hangs for some reason. Did I get the order of operations right? It’s important. This is the kind of granularity I need.


yes the order is right. i was able to edit and save two services. the 3rd and 4th times i’ve tried to save, i get the error message that the file is not writable, i’ve ended up just deleting them. last night before the service i recorded a short part of a song before the message and was able to save that. but when it came time to save the message it would not.

I’d like to point out I too am likely getting this error. Here’s a picture -

For the record, I tried renaming the file to “letter” when exporting it as a signed 16bit pcm WAV file. And I still got this error. First time this bug has ever happened to me in all of my years using Audacity.

Click on “Help > About Audacity”.
Which version of Audacity do you have?

Click on “File > Open Metadata Editor”
Click the “Clear” button, then the “OK” button.
Now try to Export the file

That seems to have fixed it. For the record, I’m running the newest version you can get off the site by clicking the download button - so 2.0.