Saving issue

Windows 7
Audacity 2.0.3

I was recording a spoken event this evening, the recording was going fine but when I finished the recording an error popped up and said that the file could not save on the C: drive due to a lack of space, which is true. However, the default save location is set to a separate drive, E:. Seeing this I thought I would just go ahead and export the file only to find that the export and save options on the file menu were greyed out. I tried to copy the data into a new window this didn’t work either. This is probably a simple thing to solve, and although it meant that I lost the data in the end any solution to get around this or prevent it being an issue in future would be great.

If the error mentioned the autosave file (Audacity’s temporary project file for unsaved changes) that will be on C: - see .

Did you try the Stop button? If that does not ungrey export, try File > Exit. Then if you see “Save Changes?”, say “Cancel”. This might regain control of Audacity.

If you had to force quit Audacity, I would have thought Audacity would have offered you recovery of the recording when you restarted, but this depends on the autosave file existing. Have a look in the autosave folder C:UsersAppDataRoamingAudacityAutoSave. If there are any files there with .tmp extension, rename the one with the latest date to .autosave extension. Then if the audio data still exists Audacity will offer to recover the project.

Note that if you never saved a project, that audio data would have been in Audacity’s temporary folder. In that case if you had subsequently quit Audacity cleanly using File > Exit, the temporary data would have been deleted.

To avoid a recurrence, open Edit > Preferences: Directories and change the location of the Audacity temporary folder to somewhere in E: or another location where you have more space. Or save a project in E: first of all, then record into that project.


I pressed the stop button and everything was still grey.
I located the temporary file before I exited though didn’t think to change the extension.
The autosave location is already set to the E: drive, though I think I will save the project to the E: drive before recording next time.
Thank you :slight_smile:

You cannot change the location of the AutoSave folder, so I assume you mean that your temp directory was set to E:.