Saved recording LONGER than it should be

That was the best explanation of the Subject I could think of. Basically…

I record playthroughs on YouTube with commentary, and I use, obviously, Audacity to record the commentary part. The problem I have has only happened about 3 times, but it has resulted in me having to discard the recording and start again. What happens is the exported MP3 file is overall LONGER than the actual recording went on for. For instance —

I start recording video first, then start recording audio exactly 5 seconds later, so the audio SHOULD be 5 seconds shorter than the video. But it isn’t… it turns out to be .01 seconds shorter. So FAR less than even a second. This results in the audio not syncing up with the video. It’s like the audio is playing faster than it should, and so it outplays (or outruns) the video. So, a recording that should be about 00:44:46 seconds ends up being really 00:40:46. I hope I’ve explained this well enough for people to understand… I’m kinda confusing myself :laughing: I have no explanation about this problem. It’s only happened 3 times so far, but for what I need Audacity for, that’s 3 times too many.

Does anyone know of this problem? Anyone else HAD this problem? Anything? Any help would be appreciated.

When the duration is wrong, is the pitch also wrong or is the pitch correct?

We should flesh this out a bit.

I start recording video first,

How? Audacity doesn’t record video.

It’s only happened 3 times so far

In a field of…what? Hundreds?

I know this is painfully obvious, but is there anything common in the three shows that failed? They were all “American Football League” videos?

recording that should be about 00:44:46 seconds ends up being really 00:40:46.

You can get that if the computer can’t keep up with the recording. If the machine drops samples during the recording process, the playback show will later appear to play faster. So you can start by inspecting the robustness and vitality of the computer. When was the last time you defragged the hard drive? How full is it?

I know it’s rough to do with three samples, but are they getting more frequent?

Hmm, no, I don’t think so. The pitch sounds perfectly normal to me.

And to kozikowski…

Sorry, I start recording video with the Hauppauge PVR software, before starting the Audacity recording 5 seconds later.
Yes, in a field of over 100s of recordings, only 3 times it’s done this.
Not really. All used the same software, hardware, the whole setup is the same as it’s always been. I’m recording footage from my Xbox 360 using the Hauppauge software.
Hmm… I believe i last defragged about a week ago, and it’s 280Gb free of 500Gb.
I don’t believe they are getting more frequent. At the moment, when it happens it’s just completely random. I don’t know that the recording has done this until I go to edit the recordings together.

One thing I SHOULD mention, which I tried sometime after posting this, is I also tried another audio capture software called AVS Audio Recorder… and what I wasn’t expecting to find was that it did the EXACT same thing. So… it looks like it ISN’T Audacity that’s causing this problem, it’s either my laptop or Windows. But because it’s rare to happen (just thrice) I couldn’t begin to think what else could be the cause.

Thanks for the replies, though :slight_smile:

I know of no way to solve something like that. If it’s not always broken or you can’t write down the exact steps to recreate the problem, it doesn’t exist. The maintenance people will hang up on you.

A note, there are two completely different ways to approach this. The obvious one is to solve it, rejoice and continue as before. The not-so obvious way is to make it worse. If you can do something to make the problem much worse or change it, write back. Torturing the machine comes in this category.

The desperation method is to replace half the system and see if the problem reoccurs. If not, then the problem was in the half you removed. Troubleshoot as needed.

Computers do have shadow zones and this is one of them.


I thought Hauppage PVR’s were hardware devices and that they recorded audio and video? That’s what the advertisements for them seem to say.

Have you tried Effect > Change Speed on the recordings that were too long?