Saved file mysteriously deleted

Hello, I have macOS Mojave Version 10.14.6 using Audacity 2.4.2. While working on a project called Wonder Woman 1984, Audacity crashed and I had to force quit the application. When I reopened Audacity, the folder for another project I had been working on, News of the World, was just gone. I hadn’t opened it in 2 days and had no problems with it. I never renamed it or moved anything around. When I click on the Audacity Project file for News of the World, it just says that it can’t find the project data folder. After reopening Wonder Woman 1984, it showed me this log that references News of the World, which again, was saved and hadn’t been opened in 2 days. Any help with locating News of the World is greatly appreciated as I spent hours editing it.
20:49:03: Audacity 2.4.2
20:49:03: Trying to load FFmpeg libraries…
20:49:03: Trying to load FFmpeg libraries from default path, ‘/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib’.
20:49:03: Checking for monolithic avformat from ‘/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib’.
20:49:03: avformat not monolithic
20:49:03: Loading avutil from ‘/Library/Application Support/audacity/libs/ffmpeg_utils.52.64bit.dylib’.
20:49:03: Loading avcodec from ‘/Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib’.
20:49:03: Loading avformat from ‘/Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib’.
20:49:03: Actual avutil path /Library/Application Support/audacity/libs/ffmpeg_utils.52.64bit.dylib
20:49:03: Actual avcodec path /Library/Application Support/audacity/libs/ffmpeg_codecs.55.64bit.dylib
20:49:03: Actual avformat path /Library/Application Support/audacity/libs/ffmpeg.55.64bit.dylib
20:49:03: Importing symbols…
20:49:03: All symbols loaded successfully. Initializing the library.
20:49:03: Retrieving FFmpeg library version numbers:
20:49:03: AVCodec version 0x373466 - 55.52.102 (built against 0x373466 - 55.52.102)
20:49:03: AVFormat version 0x372164 - 55.33.100 (built against 0x372164 - 55.33.100)
20:49:03: AVUtil version 0x344264 - 52.66.100 (built against 0x344264 - 52.66.100)
20:49:03: FFmpeg libraries loaded successfully.
20:49:05: Error: Could not parse file “/Users/bkuettel/Documents/Writings/Filmscape Podcast/Episodes/News of the World.aup”.
Error: Could not load file: “/Users/bkuettel/Documents/Writings/Filmscape Podcast/Episodes/News of the World.aup”
20:50:26: Warning: Orphan block file: ‘/Users/bkuettel/Documents/Writings/Filmscape Podcast/Episodes/Wonder Woman 1984_data/eff/d23/’ (this is repeated for thousands of times)

The top half of that explains in the longest and most detailed way possible that you don’t have the FFMpeg plugin.

Brief Project notes:

This is one complete project.

They have to be in the same folder or location, they have to be named the same, and it has to be the name you gave them in Audacity. You can’t put the AUP file inside the _DATA folder.

The AUP file is a text file (it’s not sound). You can open it in a text editor (without saving anything) and read it. You should see the name of the Project in the programming.

The AUP contains the instructions that Audacity uses to put your show together from all the little 6-second AU sound snippets in the _DATA folder.

We’re discovering some worrisome new restrictions. You can’t actively use iCloud or other cloud or on-line storage. Audacity hates that. You can use them passively. Complete your project on the local drives, close Audacity, and then scooch your files over to iCloud. Bring them back the same way.

Audacity hates that because iCloud “pretends” to be a local drive and it’s really, really, really not. The first time Audacity tried to do rapid, real time, precision tricks on it, it falls face forward in the mud—along with your show. It’s a lot slower and sloppier than your real drives.

Did I hit it?

Are the files on external drives like USB-C, FireWire, or Thunderbolt?

Are you running out of room on your system drive? You can create some very entertaining damage on an internal drive that’s running out of room.


What exactly do you see in “Documents/Writings/Filmscape Podcast/Episodes/”?
– Bill

Thank you for the information. What is the FFMpeg plugin, and if I need it how do I get it? Sorry for my lack of knowledge about Audacity, I’ve only recently started using it consistently.

Just to be clear, I never messed with any of my Audacity projects by moving their location or putting the AUP file inside the Data folder. I also didn’t put anything in iCloud or on external drives, though after this happened I backed everything to a flash drive in case Audacity crashes again. My Mac hard drive recently became over 90% full, and I’m going to make more room soon.

To answer the second question, in Documents/Writings/Filmscape Podcast/Episodes/ it’s just my other project files in Audacity format, both the _Aup and _Data folders, and some mp3 versions. The News of the World AUP file, but the _Data folder is nowhere to be found and what I’m looking for as I said. I’ve searched the whole computer and ran a data recovery application but no dice. I’m guessing it’s just been wiped permanently but am exploring all avenues to get it back.

Just for future reference - It’s a good idea to export your audio as WAV (if it’s not already backed-up) whether you save a project or not. Projects are a little more “fragile” because they contain many small files in a particular file/folder structure. I mostly do “simple things” and I don’t bother making a project.

What is the FFMpeg plugin, and if I need it how do I get it?

It’s an optional package of CODECs (coders / decoders) that allows you to import/export a variety of audio formats that Audacity doesn’t natively support. For example, Audacity can import/export WAV & MP3, but for MP4 or to extract the audio from most audio/video formats you need FFmpeg. If you’re not using any of those formats you don’t need it.

20:49:03: FFmpeg libraries loaded successfully

You have the FFmpeg library installed.

Given the timings of the log messages it looks like you double-clicked on an AUP file which started Audacity.
It appears that the AUP file you double-clicked was “News of the World.aup”.

Please open the “News of the World.aup” file in TextEdit. Copy and paste the first 10 lines of the file into a message here.

– Bill

Hi Bill, here is the News of the World file when I open in TextEdit:

<?xml version="1.0" standalone="no" ?>
<!DOCTYPE project PUBLIC "-//audacityproject-1.3.0//DTD//EN" "" >
<project xmlns="" projname="News of the World_data" version="1.3.0" audacityversion="2.4.2" sel0="0.0000000000" sel1="0.0000000000" vpos="0" h="0.0000000000" zoom="0.5026702285" rate="44100.0" snapto="off" selectionformat="hh:mm:ss + milliseconds" frequencyformat="Hz" bandwidthformat="octaves">
	<wavetrack name="Audio Track" isSelected="1" height="150" minimized="0" channel="0" linked="1" mute="0" solo="0" rate="44100" gain="1.0" pan="0.0" colorindex="0">
		<waveclip offset="0.00000000" colorindex="0">
			<sequence maxsamples="262144" sampleformat="262159" numsamples="53747266">
				<waveblock start="0">
					<simpleblockfile filename="" len="253107" min="-0.440385" max="0.593263" rms="0.037685"/>
				<waveblock start="253107">
					<simpleblockfile filename=""

News of the World_data

How did you search for the News of the World_data folder?

I’m not the biggest fan of Mac Spotlight Search. I know there are ways of making text-only Terminal do a search. Someone with Linux talents can comment.

What can cause a _data folder to vanish that hard with seemingly no cause. The show wasn’t open at the time.

I don’t suppose you do automatic Time Machine backups? Do you have virus protection software?


OK, so the News of the World.aup file should be looking for the “News of the World_data” folder.
This conflicts with your log:

Orphan block file: ‘/Users/bkuettel/Documents/Writings/Filmscape Podcast/Episodes/Wonder Woman 1984_data/eff/d23/’

Did you double-click both files at once?

If you attempt to open the News of the World.aup file, what happens? Again, show us the log.

I’m trying to interpret the log file, and it looks like News of the World.aup is damaged (“unable to parse”, “unable to load”)

– Bill

The log for the News of the World file is in my first post. That project was not open when I was working on Wonder Woman 1984 and Audacity crashed.

But I just achieved a semi-breakthrough: I went into the depths of the Wonder Woman 1984 folder, and I found little 4-6 second snippets of News of the World audio among the Wonder Woman 1984 ones. I guess the crash made them combine into the Wonder Woman 1984 folder? When I open Wonder Woman 1984 and my other projects, they all still play normally.

I attached a snapshot of what the folders look like here. I’d love a way to sort out the News of the World ones so I can just link them all together and restore that project, but they all look pretty randomly sorted. The Wonder Woman 1984 project is all done now and exported into an mp3, so maybe one avenue is to wipe those snippets, so I can isolate News of the World and bring it back?
Screen Shot 2021-03-03 at 10.36.55 PM.png

find <path> -name <filename>

Example, to search recursively for a file that begins with “News”, starting from the current folder:

find . -name News*

The dot means “the current folder”.
The asterisk is a wildcard for any characters.

The reason I asked you to try to open News of the World.aup again is that I don’t understand how you could get the following error message when opening that file:

Warning: Orphan block file: ‘/Users/bkuettel/Documents/Writings/Filmscape Podcast/Episodes/Wonder Woman 1984_data/eff/d23/’

especially after getting the message that News of the World.aup could not be opened, and since News of the World.aup does not reference the Wonder Woman 1984_data folder.

So, could you please try this:
Start Audacity
Using File > Open, open News of the World.aup

– Bill

You might get lucky with this procedure.

Duplicate the Wonder Woman 1984_data folder
Rename the duplicate folder “News of the World_data”
Make sure “News of the World.aup” and “News of the World_data” are in the same folder.
Start Audacity
Open News of the World.aup

You may get a message about orphan blockfiles. Those would be the ones for the Wonder Woman 1984 project. Since you’re dealing with a copy of the folder you can safely delete them.

When I open Wonder Woman 1984 and my other projects, they all still play normally.

This is strange. If the News of the World data is mixed in with the Wonder Woman 1984 data I would expect you to get a warning about orphan blockfiles when opening the Wonder Woman 1984 project.

– Bill

Hi Bill, thank you so much for that neat trick, it seems to have worked and my News of the World project is now fully restored! I’m off to export immediately so I don’t lose it. That’s something everyone should know I would think, if that happens to anyone else where all the files are mixed together due to a crash or something. Also you are correct that every time I open Wonder Woman 1984 it gives me a warning about orphan block files, which I had suspected and is now confirmed that they belonged to News of the World. It doesn’t give a way to listen to them or anything.

This thread can be closed or archived or whatever, as my issue has been fixed. Thank you again!

My suggestion was, frankly, a long shot. Glad it worked.

I don’t think I’ve even seen two projects mixed together like that in the _data folder, plus the original _data folder going bye-bye.

This will, thankfully, all be a thing of the past when Audacity 3.0 is released (real soon now).

– Bill

Excellent troubleshooting Bill :ugeek:

Neither have I, but as you say, we shouldn’t need to worry about this for much longer.

Neither have I, but as you say, we shouldn’t need to worry about this for much longer.

Audacity 3 is expected to open up older shows, right? It just won’t make new ones in the old format?


As you’re a very experienced Audacity user Koz, there’s a pre-release version available:

Yes, it deals with projects all the way back to 1.2.6 - I tested recently after some fixes that Leland made.

It also deals with older projects that have aliased files (provided the aliased files still exist and are in the right place) - it does copy them in though, so the alias link no longer exists once its been made into a UP-3.0.0 project.