Save Project Comes up Automatically

I recently updated to the latest version of Audacity, and an encountering an annoying thing which started. I was tinkering with my recording settings, to get a clearer recording without the sound of air when there was no talking. I think the setting I changed was in my Windows settings after all, but the recording is amazingly crisp now, better than any I have experienced before.

However, somewhere in the process I think I may have changed something, or it’s a new feature in the latest Audacity…but whenever the recording is done, it is automatically bringing up the save project dialogue. I do not want to save the audio this way. Every time I am closing it and then exporting the file. It’s not a huge thing, as anyone will notice, but I never had the problem before. I could sit down, clip the extra time I gave it at the end, trim the beginning to wear the audio starts, and then export as an .mp3

Yet with this new version, it is making me click cancel, every time, and if I am working else where on the computer, it will pop up over whatever I am working on or typing, if the recording completes in while I am on the computer. I can’t find anything that answers it already in the forum, nor the faqs, and nor on a general Google search. I also can’t find an option to turn it off in the preferences, but I am thinking I might be missing it, because not many programs make decisions like that for you.

Does anyone know if this is in there on purpose, or am I missing it, on how to turn it off? Thanks so much!


Are you using “Timer Recording”? (

Yes I am. Though it was happening when I was even testing my new recording settings, and I would record for ten seconds, and then stop to listen to my sample. I’d hit record, wait a little, hit stop, and then have to cancel the save dialogue to replay what I recorded. Now that it is set up properly, I am back to using timing record.

I’ll mention also that I have been using timer record for a long time now, even in the previous version for months, and can’t remember having to close this dialogue to immediately work on my clip for exporting.

Ok my reply isn’t up yet, but I went to that link on the timer record and see there is some details about that, including something about turning off the warning dialogues. I DID search using keywords such as save dialogue pops up, save dialogue automatic, or save dialogue automatically, and didn’t see anything. I do seem to end up with a little pie on my face, when I ask questions and you guys know instantly what the issue is. :confused:

I’ll take a look at that some more and see if I can solve my problem. Thanks so much! :slight_smile:

If you have not already saved a project you can’t use Timer Record without it trying to save automatically. I said at the time there should be a checkbox in the Timer Record dialogue to enable prompting to save the project.

If you turn off the warning for “Save Project” you will instead have to cancel the file save dialogue, assuming you don’t want to save a project.

A workaround would be to Tracks > Add New > Mono or Stereo track, zoom out, select the length you want to record by dragging in the empty track, make sure Transport > Overdub is selected, then Record.


What a pain. Options are the best things in the world. If I don’t want to save my recording, and immediately want to edit or export it I should be able to. As I said, it’s not a huge thing to click cancel, but if I have to do all that to avoid it coming up that’s nuts. There should be an option to turn off the automatic save dialogue.

I’ve noted your “vote” for an option in Timer Record not to prompt. However only a few people have felt strongly enough to complain so far.