Sampling tools needs to take control of another process

Help please,

Has anyone experienced a problem where Audacity is not working with a Mac Mini Sierra Operating system 10.12.4 and Audacity Version 2.1.3?
I launch the program but it won’t record. It sits frozen. When close out. I get a colorful spinning wheel and two error messages.
Incidentally, the same Audacity program (version 2.1.3) is working perfectly with my MacBook, which is also loaded with the same Sierra Operating system.
However on the desktop, I’m getting these two error messages.

The first says, “Sampling tools needs to take control of another process for debugging to continue.”

Then the second displays the reports which say, there was a problem with:

Audacity.xml (process context description)
audacity.cfg. (Audacity Configuration)
pluginregistry.cfg (Plugin Registry)
pluginsetting.cfg (Plugin Settings)
log.txt (AudactiyLog)

Screen Shot 2017-05-02 at 5.45.52 PM.png
Screen Shot 2017-05-02 at 5.45.21 PM.png

It smells like you still have a permissions problem…

When you upgraded to Sierra, did you do a clean install?

You wouldn’t happen to have ProTools installed? Or had it installed some time in the past?

Sierra still is a bit of a pita for some, when iy comes to audio. If you already tried setting the latency in Audacity, it’s beginning to look like you might need a clean install…

I split this off from your other topic Audacity crashes - #14 by Gale_Andrews where you are complaining about an unspecified “latency problem”.

Not enough detail. What device are you recording with? Is it your new RME Babyface? What are the exact symptoms of “won’t record”? Does the red record cursor appear but not move?

Have you installed Xcode on this machine? It’s a developer tool by Apple. Have you installed any new audio software on this machine?

The message about sampling tools does not come from Audacity but is triggered by the crash. So we need to know why Audacity crashes. Tell us whether you do File > Close or Audacity > Quit Audacity before the crash.

And please post the Audacity debug report ZIP file. There should be a dialogue that tells you where it is exactly, but it will be in /var/folders./ To produce the debug report, you have to press OK in the Audacity debug report window. See Help Menu - Audacity Manual for more help.

Do you see also see a dialogue from Apple telling you that Audacity crashed unexpectedly? If so, press the “Report…” button in that dialogue and post that report. Find the section in the report that says “Thread crashed” then skip to the end of the section for that thread. Then drag a selection from the end of that section up to the top of the report and Command + C. Then paste that in this topic.


I think I’ve just found the problem. I don’t believe it was the Audacity or the Sierra. I now believe it was an older audio interface that may not of been compatible with the Mac which could’ve caused issues. I replaced the audio interface and I’m up and running great now. Many thanks

I have this same error window.
Mac Pro 5,1 running OS 10.12 Audacity 2.1.2
I own ProTools, and make mixes through my outboard gear, then usually use Audacity to bounce out mp3s of that mix for a client. I like to slightly “master” them, mainly just to make them louder, so I often will use a plug to goose it up a tad.
The error window pops up when I run any plug in from the Ozone suite by Izotope. It’s fine while running the process and exporting the file. It’s just than when I quit Audacity I see this error window, which leads to a Debug Report window which leads to an app crash (pinwheel and then a force-quit of Audacity is the only way out).
Other plug-ins don’t have the problem, even others made by Isotope (Neutron, e.g.)
Is it a permissions thing? Is that something I can fix without doing a re-install ( I believe this started happening about six months ago when I did an update of the Isotope plugs).

Let me know if you need any further info. Thanks!

You could try updating Audacity. The current version is 2.3.3 and you can get it via the Audacity website:
I don’t know if that will help - it sounds like the updated Ozone plug-ins are incompatible with Audacity.