Ringmod Plugin

I’m working with the Ringmod plugin, and I have a Sine wave tone of 400 Hz. I want to modulate it with 17 Hz, but when I try to do that with the Ringmod plugin, I get an error that says I can’t modulate with a tone below 20 Hz. How would I fix that?

Change the line:

;control mod "Modulation frequency" real "Hz" 500.0 20.0 5000.0

so that the minimum is low enough for your needs.

Interesting that I did change that line, but I somehow still get that same error. What did I do wrong?

What did you change it to?

I tried to change it to 10.0, but the same error still comes up, that it is ourtof the range of 20.0-5000.0. What do I do next?

You probably made a typing mistake. If you copy and paste your modified line I can tell you where the error is.

;control mod “Modulation frequency” real “Hz” 500.0 10.0 5000.0

Perhaps, you’ve modified the wrong copy of this file, i.e. from the wrong plug-in folder.
Do you have different Audacity versions on your PC?
I surely have and do sometimes fall into this trap.


The version of Audacity I’m working with is 2.1.1, which I believe is the latest version. However, the Ringmod Plugin I have says it’s “version 1”. I believe I downloaded this plugin from the Audacity Wiki.

Th code looks OK, but as Robert suggested, you may have more than one copy of the plug-in on your computer.

I’ve now fixed it so there’s only one copy within Audacity. The most recent version that is marked 2.1.1.