Reverting back to 2.4.2


I am using Linux Mint 19.3 and had successfully installed Audacity 3.0.0. However I have discovered tonight that my Compress Dynamics plug-in which I use all the time no longer works.

I have tried removing/uninstalling 3.0.0 which seemed to work but I cannot reinstall 2.4.2 for love or money. I have tried Synaptic and Software Manager.

Initially it seems to work but then I get a Floating point exception (core dumped) error.

Is there anything I can do to get 2.4.2 back?

Thank you

When does that error occur?

Hi Steve

Just when I try and start the program. Well, at first, just starting the program did nothing, so I started it from a terminal to see if I could spot any error messages.

I might be on the way to fixing it though…

Have you tried resetting Audacity’s configuration?
(Delete the “~/.audacity-data/” folder).

I’ll give that a go now - for the moment, 2.4.2 seems to be working… of course, the other issue is what do I do about the Compress Dynamics 1.2.6 plug in and 3.0.0 if indeed it doesn’t work moving forwards

There’s a problem running Nyquist effects (including “Compress Dynamics 1.2.6”) on selections over about 45 minutes in Audacity 3.0.0. The workaround for now is to process long tracks in shorter sections.

Today I’ve been testing a fix for that and the fix looks good. Audacity 3.0.1 is scheduled for release next month.