reverse delay (5s max)

Bonjour à tous.
J’essaye d’utiliser ce plugin Ladspa. Il y a un problème avec les presets.
_ Les commandes “import” et “export” sont inacessibles (elles restent grisées).
_ Lorsqu’on enregistre des presets personnelles, celles-ci sont inutilisables. Quand on sélectionne une preset, aucun réglage ne change dans le plug-in.
_ La preset d’usine (“Defaults”) ne change aucun réglage non plus.
Quelqu’un aurait-il observé ces problèmes?
D’avance merci pour votre réponse.
Hello. I use Audacity 2.1.0 under Vista 64 bits and Height 8.1.
I try to use this plugin Ladspa. There is a problem with presets.
_ The commands"import…" and “export…” are inacessibles (they remain tinted).
_ When we record user presets, these are unusables. When we select a preset, no regulation changes in the plug - in.
_ The preset of factory (“Defaults”) changes no regulation either.
Would anybody have observed these problems?
Beforehand thank you for your answer.

That feature does not work yet, as it says in the Manual:

No - recalling User Presets and setting Defaults works for me in Reverse delay (5s max) and the other swh-LADPSA plugins I tried (like the shipped SC4). I tried running Audacity in English and French. I’m using Windows 7 at the moment.

Have you tried exiting Audacity then deleting Users<your user name>\AppData\Roaming\Audacity\pluginregistry.cfg?

If the problem continues after deleting pluginregistry.cfg, can you write out exact steps 1, 2, 3… that makes the problem happen, including exact values of all the parameters in reverse delay?

By the way, Audacity Team members do not monitor the localised Forums or undertake to provide support for them (because we only speak English, see the pink panel at the top of the page). Your reports of problems are welcome but it’s only chance that I happened to notice your posts - which means there is a chance your posts will not be answered if you post in the French Forum.

So if you are reporting a bug, I would post to


Rather than to change forum, I answers this message on the same forum. I shall change forum another time.
Thank you.
I cannot has to remove the file (pluginregistry.cfg). As soon as I open Audacity, the file is automatically created.

Concerning reverse Delay (5s max).
_ I open Reverse Delay (5s max).
_ I move cursors.
_ If I click Factory Presets\Defaults, cursors do not take back their initial place.
_ If I move cursors.
_ I select “Enregistrer sous…”
_ I give a name to the user preset.
_ I select User Presets.
_ I choose another user preset than I have already registered.
_ No cursor change position.
I think that there is a problem. I use Windows Vista 64 bits; and Windows 8.1 64 bits.

That is good, thank you.

Yes it is intended that the file is recreated. There is always a possibility that the file has been corrupted somehow, if so deleting it will hopefully fix any corruption.

Sorry but I still cannot reproduce that problem, even if Audacity is in French language, chosen in the Audacity Preferences. This time I tried in 2.1.0 and not 2.1.1-alpha.

Similarly I still cannot observe that problem.

Can you try exiting Audacity then deleting pluginsettings.cfg. It will be in the same folder as pluginregistry.cfg. The pluginsettings.cfg will be recreated when you apply the reverse delay, even if you do not change its settings. If you do not want to lose your other plugin settings, please copy the pluginsettings.cfg file to another location then you can move it back later.

If the problem continues with the new pluginsettings.cfg file, please attach that file and attach the “revdelay_1605.dll” you are using. Please see here for how to attach files:


I fail to understand English, also, I did not understand your message. Sorry.
What I can say, it is that the problem is common to all the plugins LADSPA. The command " Defaults " is of no effect. The problems that I evoked for the plugin Reverse Delay (5s max) are identical for all the plugins LADSPA on Vista 64 bits and Height 8.1 64 bits.
Sorry for the english!

Sorry, but on my machine the problem does not occur. If we cannot make the problem happen then it will not be fixed.

Please exit Audacity then delete the file Users<your user name>\AppData\Roaming\Audacity\pluginsettings.cfg. Then test if the problem still occurs in Reverse Delay.

If the problem still occurs, attach the file Users<your user name>\AppData\Roaming\Audacity\pluginsettings.cfg to your message.

Find out where you installed the Reverse Delay plugin and attach that file also. The plugin should be called “revdelay_1605.dll”. Alternatively, tell us the exact web site you obtained that plugin from.

Please see here for how to attach files:


_ The plugin LADSPA revdelay_1605 is placed in:Windows (C:)\Program Files (x86)\Audacity\Plug-Ins
_ All the plug-ins LADSPA are in the same place.
_ I downloaded these plugins on the official site of Audacity (LADSPA_plugins-win-0.4.15).

When I click “Defaults”, the only thing which takes place is that the values with decimals change (for example: 0.2000 becomes 0.2).
On the other hand, as I have already indicated it, no modified parameter finds its initial position. It is similar for all the plugins LADSPA.

Sometimes, for some plugins LADPSA there is something strange.
_ I change the position of one cursor.
_ If I change the position of a second cursor, the first cursor takes back its initial position immediately.
revdelay_1605.lsp (100 KB)
pluginsettings.txt (1.06 KB)

Thanks for the files. I can now reproduce the problem, but only if I set Windows Region and Language Format to French (or to some other language that uses comma as decimal separator).

I reported the bug here:

Thank you. I cannot reproduce that problem but I have mentioned it in the bug report.