Repeat recording issue

Hi, I’m new to Audacity and I cant seem to NOT record every previous track onto the next one! All I want is to have a designated track for each instrument, or different tracks for each keyboard sound. So, consequently, I put down a click track first, then a keyboard track, then another keyboard track, but everything appears on the new track. So, I can never get rid of the click track cos its on every track, with everything else! If I reduce the playback volume on a particular track, it turns everything down! Nightmare! Can someone PLEASE tell me how to record only the instrument I’m playing on any particular track please and not have everything I have already recorded appear on that new track aswell? I hope it’s something simple, it probably is! Many thanks

How are you recording the instruments? (for example: “I am using a Samson CU1 microphone, plugged into a Fostex Phoenix II USB pre-amp, which is connected to the computer with a USB cable.”)

What have you set as the “host”, “Recording Device” and “Playback Device” in the device toolbar?

Hi Steve, I’ve connected my Korg Kross 2 to the desk (Allen & Heath Zed 16 FX). Then, I’ve connected the desk to my PC via the USB on the desk.
I open Audacity and lay a click track. Then, I go to the ‘tracks’ tab on Audacity and ‘add track’. I play the keyboard with the click track. Then, I want to lay another keyboard track so I again go to ‘add track’. Another track appears below, I click record and record the keyboard, still hearing the first track and click.

Every additional track I open records every previous track at the same time, so by the time I have done 5 tracks of keyboards, the 5th track has everything on it! So, its impossible to mix levels on each track as, apart from the original click track, they all have the previous track on them! E.g. track 1, then track 2 (1+2), then track 3 (1+2+3), etc.

Now, I am using the same channel on the desk for all the keyboard tracks, cos I guessed that’s the desk and surely Audacity notices that I’m only playing one instrument at a time. Someone told me I should record a keyboard track on the first track of Audacity, then if I want to record another keyboard track, I should plug it into a different channel on the mixer!? I’m obviously doing something stupid here!

I am very new to Audacity and need to know what settings to have for this, what should be a straightforward, process. Any help at all would be appreciated. Thanks.

P.S. Recording device is set to 'Microphone (USB Audio CODEC), which is what I need for the PC to be able to hear the desk.

Is that the only USB Recording option in the device toolbar?
What are the “host” and “playback” settings?

Where are your headphones plugged in? (I assume you are using headphones to listen to Audacity).

Hi, the only other recording option on the toolbar is 'Microsoft Sound Mapper input. Its definitely recording the playback aswell as the instrument im playing while recording. I listen to previously recorded tracks through the USB return via the monitor speakers while I’m recording the next track. Although the headphones are plugged into the desk, I tend not to use them as a monitor. Maybe I should!? But, the playback while recording is definitely being recorded again down to the next track. Any ideas? Thankyou

As I can’t see your computer, I’m trying to build a mental picture of your set-up. Have I got this right:

Recording:
Korg Kross 2 → (analog connection) → Zed 16 FX → (USB) → computer

Playback:
Computer → (USB) → speakers

Please do this:

  1. “Help menu > Audio device info”. Wait for the “info” window to appear, then click the “Save” button. Save the the info file somewhere convenient.
  2. Attach the “deviceinfo.txt” file to your reply (see here for how to attach a file to a forum post: https://forum.audacityteam.org/t/how-to-attach-files-to-forum-posts/24026/1)

deviceinfo.txt (7.11 KB)
Hope thats ok. thankyou

Set the device toolbar like this and see what happens:

host = MME
Recording input = Microphone (USB Audio CODEC )
Playback output = Speakers (Bose USB Audio)

Hey Steve, thankyou very much!! Seems to be ok. 2nd track now only records what I play and NOT what was already on the 1st track. When you have a moment, could you explain why, when playback through the desk speakers ( USB Audio CODEC), it decides to record onto all other tracks? Also, does this negate using my headphones through the desk when listening to previous tracks and recording a new one? Thanks again!

Your settings now:

host = MME.
MME is the default Windows audio driver. It provides good compatibility with most audio hardware.

Recording input = Microphone (USB Audio CODEC )
“USB Audio CODEC” is the name of the Windows audio device driver for the Zed 16 FX mixer. So you have told Audacity to record from the mixer.

Playback output = Speakers (Bose USB Audio)
“Speakers (Bose USB Audio)” is the name of the Windows audio device driver for your Bose USB speakers. So you have told Audacity to play through the Bose speakers.


If you wish to play back from Audacity through the mixer, then you would need to change the Playback output setting to “Speakers (USB Audio CODEC )”.
Note that there “could” be a problem doing this. I’m unfamiliar with the Zed 16 FX USB, so I don’t know if this will be a problem or not - you may need to refer to the Zed 16 manual if you want to use this option.

The “possible” problem with selecting the Zed 16 mixer as the playback device, is that it “may” loop the data that you are sending to it, back to its USB output, which would then cause the same problem that you had initially, of the Audacity playback being recorded to new tracks. Hopefully this won’t occur, but I’ve seen some USB mixers do this, so thought it worth warning you about.


If you want Audacity to play back through the “Realtek High Definition” (I presume that’s your computer’s built-in sound card, then you would set Audacity’s playback device to “Speakers (Realtek High Definition)”

I think I’ll stick with this for now. I think you may be right about the mixing desk looping it back to re-record. That shouldnt happen but seems like it is. I’ll contact Allen & Heath for some advice on that. Thanks again for your help Steve!

Your original settings were:

host = WASAPI
This is a relatively new type of sound system for Windows. It has some advantages over the older MME system, but it can be a bit quirky and difficult to set up. Also, some audio devices (most commonly older devices), can be quite buggy with this setting.

Playback output = Speakers (USB Audio CODEC )
This is telling Audacity to play back through the Zed 16 mixer


Recording input = Microphone (USB Audio CODEC )
This is telling Audacity to record from the Zed 16 mixer


Here we can see the problem that I warned about in my previous post. When using WASAPI and both recording and playback are via the Zed 16, the audio that Audacity is playing is being looped back to Audacity’s input. Whether or not this problem will also occur when using MME, I don’t know - it depends on the mixer and the drivers. There may be a setting to enable / disable this “loopback” behaviour.

Just a thought, if you try to look this up in the Zed manual, they may call it “through” rather than “loopback”.