Rendering issue on track list [SOLVED]

I’m using Archlinux I3 gaps windows manager, Audacity v2.3.3 from Arch community repo.

Everything seems to work but track list is not rendering correctly.
By ‘not rendering correctly’ I mean, It does not redraw contents when it’s supposed to, like when I scale tracks, I drag other window over there, etc.
I attached screen capture for reference.

Log output:

Thanks for working on this great software, I hope it gets fixed soon :sunglasses:

Are you using Wayland? If so, then as a test, try logging into an Xorg session.

No, I’m using Xorg.

This looks like it’s an incompatibility between WxWidgets and i3 (see issues #539 and #2395 on

Which version of WxWidgets has Audacity been built with? Is it using gtk2 or gtk3?
The minimum required version for Audacity is wx3.0 the recommended version is wx3.1.1 with gtk2.

I’m using Archlinux prebuilt binary so I can’t tell exact version.
But from package dependency list (
It looks like it has been built with wxgtk3 and gtk3. I will try building development version with gtk2.

You are right, I built development version with wxgtk2, and it works fine.
What I did is installing wxgtk2 package and modifying PKGBUILD from AUR (

build() {
  cd "$srcdir/$_pkgname"
  WX_CONFIG=wx-config-gtk3 ./configure --prefix=/usr --with-libsamplerate


build() {
  cd "$srcdir/$_pkgname"
  WX_CONFIG=wx-config ./configure --prefix=/usr --with-libsamplerate

(just in case someone else bumps here for same issue)

Thanks for getting back to us with this information.
I’ll close this topic as “solved” so that it is easier for others to find.

Update: This issue has also been logged on the Audacity bug tracker.