when I record singing to backing track I get music from backing track on vocal track ,on windows 10 audacity 2.1.3 .exe installer, record through YAMAHA MG10XU . I’m new to recording so need bit of help please .

Go to Windows recording devices, and ensure that only recording from “line-in” is enabled, (from your Yamaha mixer),
and “stereo-mix”, (which is the sound from the computer’s speakers), is disabled as a recording device.

[ I’m assuming your problem isn’t acoustic : sound leaking from headphones and being picked up by the mic ].

Hi have checked not recording backing track from head phones, unable to find stereo mix to turn it off from what information I have found on it you are not able to access stereo mix in windows 10 if I turn speakers off can’t hear track to sing too .My problem recording low sound of backing track means when I add effects to voice in audacity also affects the recorded backing track which does not need any ,Will I need to buy usb mike to record just vocals when singing to backing track. Thanks

To see Windows recording devices, (like “stereo mix”), put the cursor over the Windows loudspeaker icon, then press the right mouse button, then something like this should appear …

Disable all the Windows recording devices you find, except “line-in”, which is your mixer.

have right clicked speaker icon disabled conextant smart audio audio HD audacity still records low sound of the backing track with the voice ?

If your mixer is connected to the computer via USB, (rather than “line-in”), that could be a way for the backing track to leak out.

yes mixer connected by usb but if I put switch to line I can’t hear track to sing through .

There must be control somewhere on the mixer to stop the loop-back …