Red Triangles

Audacity 2.4.1
Windows 10 Home

When setting up to record vocals and/or guitar etc the recording will not proceed & the green triangle at the start of the recording turns red, plus another appears. The recording will not start. I unsubscribed Audacity 2.3.3 & re-downloaded Audacity 2.4.1 but the problem still exists. I’ve tried unpinning, switching on & off etc but no joy.

This has occurred without me changing a thing. I have read the manual & FAQ’s but can’t find any solution. If anyone can, please help.


What sort of microphone do you have and how is it connected to the computer?

What are your settings in the Device Toolbar?

Hi Steve,
Sorry for delay getting back to you. Settings in Device Toolbar are MME, Microsoft Sound Mapper & Mono. I hope that’s what you meant.
Cheers Laney

Hi Steve
PreSonus condenser mic M7 going through PreSonus AudioBox iTwo. But nothing happens at all with the condenser so I tried a Shure SM58 which seems to register sound, but still no recording.

The PreSonus M7 requires “phantom power”. On the AudioBox there should be a button to switch on phantom power. To prevent possible damage, it is recommended to turn off phantom power before connecting or disconnecting the mic from the pre-amp.

Ensure that the Presonus is securely plugged into the computer’s USB port, then in the Audacity Device Toolbar, set the Recording input to the USB option.

Hi Steve
Thanks for the advice about phantom power for the M7, it now works. I’ve also set the device box to USB but whatever I do, as soon as I set everything up to record & press the button, the green triangle immediately changes to two red triangles & won’t record. This happens in both channels 1 & 2 (mic & instrument). As soon as I press the STOP button the triangle changes back to green & the second one disappears.

  1. “Help menu > Diagnostics > Audio Device Info”
  2. Wait for the info window to appear
  3. Click the “OK” (or “Save”) button, and save the info somewhere convenient.
  4. Attach the saved “deviceinfo.txt” to your reply. (

Hi Steve
Thanks for the assistance. I’ve saved deviceinfo.txt & attached.
Cheers Laney
deviceinfo.txt (6.8 KB)