Red triangles yet again

I see there have been a few questions about the Dread Red Triangles, but different fixes seem to be working for different situations, and none so far for me.

I can record with Audacity using my Behringer desktop mic or my webcam. And the last time I tried (months ago) I could record using my Zoom H2 as well.

But as of today it’s doing what you see in the attached jpg:

  1. I can select the H2 as the mic I want to use, and all looks well,

  2. But when I click Record it shows the red triangles and won’t do anything else.

red triangle.jpg

Hmmm, 21 views so far, and no advice?
I’m in trouble all right

Which version of Audacity are you using? (look in “Help menu > About Audacity”)

Do you still have the problem if you set the “host” to “MME” in the Device Toolbar?

Have you checked that the H2 is set in “USB microphone” mode ?

Have you tried “Transport menu > Rescan Audio Devices”?

Have you got Sound Activated Recording turned on by any chance ?



Thanks so much for your help!

I’m using Audacity 2.4.2.

It’s not set to “sound activated.”

When I change it to MME or Windows Wasabi I get the same result, even when I close and reopen Audacity between tries.

When I look at Sound Devices and click on the H2 it gives me the image below. It comes up already set to “H2 Audio”.
When I click instead “USB Composite Device” the “Apply” button does not light up. When I close and reopen it, it’s on “H2 Audio” again.

Further advice?
H2 properties.jpg