Records only the vocals when recording from a phonograph

Windows 11, Audacity 3.2.1
I got a new laptop to record from my stereo receiver, via a Behringer UCA202. I used it on my old laptop (Windows 10) but on my new laptop (Windows 11), it doesn’t record well. It records only the vocals, so maybe it’s just recording the loudest stuff and dropping the rest.
I use the identical settings on the old and new laptop:
Windows Direct Sound
Microphone (USB Audio CONEC)
2 Stereo Recording Channels
Primary Sound Driver
In Windows setup, the microphone setting uses 2 channels 16-bit 48000, and I’ve tried 41000 too

Windows* audio-enhancements can be on by default,
All such enhancements (recording & playback) should be disabled for a faithful recording,

[ * there may be another layer of audio enhancements that need to be turned off , e.g. Dell/MaxxAudio ]

If that doesn’t help…

Is this one of those rare records with the vocals on the left or right?

Try unplugging the left & right connections one at a time and maybe reverse the left & to see if anything unusual happens.

Problem solved by uninstalling and reinstalling Audacity. I don’t know why that worked, but I’ll take it! I reset preferences when installing, so maybe I had set something the wrong way.
Anyway, thanks for the input!
For the record (rimshot), I tried a bunch of different recordings. It did the same thing on mono records as stereo. Classical records with no vocals were almost silent. Sometimes the vocals were crisp and near-perfect; a great way to isolate vocals! Mostly, the vocals were smeared and weird.
And now, I just have to record one box of 45s and one box of 78s and the LP-to-digital project will finally be finished.