recordings with low pitch and dropouts

Hello, all. I’m returning again for help on an issue I first wrote about back in February. Since then, I’ve noted a number of other Audacity users reporting more or less the same problem, but the solutions suggested to them are not working in my case.

The problem I am having is are actually two: low pitch on recording an initial track, and dropouts (as well as low pitch) on overdubbed tracks. These problems arise when using an audio interface with my mics; in my case, an Alesis io2.

Until today I was using an older Audacity release, 2.1.2. I had been using that version for several years with very satisfactory results until my last successful recording project in October. My next project, this past January, was the first time I encountered the present problem. Between the two dates, there was no change to the recording hardware (mics, interface) or the computer I was using—an HP Envy running Windows 10.

Today I upgraded to 2.3.3 hoping that might provide a solution, but it didn’t. The only benefit Is that the new version definitely diagnosed the problems with the overdubbed tracks as dropouts, and suggested possible causes in a pop-up window: that other applications are competing with Audacity for processor time, or that I’m saving directly to a slow external storage device. To address the first possibility, I shut down all other programs and applications and disconnected from the internet; there was no improvement. Regarding the second possible cause… well, I’m not recording to an external device, I’m recording to the same computer hard drive I’ve been using for years.

For the others reporting essentially the same low-pitch/dropout issues, either together or separately, I’ve seen suggested solutions like changing the project rate from 44100 to 48000 (or vice-versa), increasing the buffer size/latency, using a different USB port in the computer, even unplugging the USB cord from the interface and plugging it back in. Such fixes may have helped the others, but none worked for me.

The only change on my computer between last October and January was that I subscribed to a VPN in November. I don’t know why that might have made a difference; still turned it off it just like all other applications so that Audacity was the only thing running, but the results were the same.

I’m completely lost. I’ve searched the manual, the forum and the wiki for solutions but am coming up empty. I made sure Windows was updated and I individually updated every driver I could think of. I don’t know what else to do.

If someone knows what’s causing this problem and how to fix it, I would be very, very grateful. Thanks for any advice.

Usually, it’s “something else” hogging the system. I the buffer doesn’t get read in time you get buffer overflow and a glitch/dropout. And, it doesn’t have to be something using a lot of total CPU time. It just as to hog the system for a few milliseconds too long.

There is a free online book about optimizing your computer for audio called [u]Glitch Free[/u].

The pitch issue may be something different. If dropouts cause a speed/pitch problem, usually it plays back faster, at a higher pitch because little bits of audio are missing and you end-up with a smaller file.

Are you playing-back through your regular soundcard or through the interface? Sometimes the clock in a consumer soundcard is off. If you record on one device and play-back on another you can get pitch/timing issues if the clocks don’t match.

Thanks for the link. I’ll review the guide, but to be honest at this point, though it’s likely to have good general info I’m not very encouraged it will have the answer to this problem. Its onset just seems to be a mystery. In October, everything was working fine. Just a few months later, all of this is happening. The only significant factor in the interim is the addition of a VPN.

I’m listening to the playback through the internal soundcard, just as I was doing before things went wrong. I don’t think that’s a factor because the new Audacity release confirms the dropouts are in the recording, not the playback. I have no reason to think the slowed-down pitch issue isn’t similarly a product of the recording.

As I noted, I’ve tried turning off every application besides Audacity, and unhooking from the internet, and it’s still the same result. I’ve run out of things to shut down. I am very hesitant to turn off processes that are part of the computer’s operating system because I absolutely won’t know what I’m doing there. But maybe the guide has some advice about that.

In any case, these recording problems are not/not present when I use the computer’s internal mic. To me then, that would indicate the problem is not related to what the computer is doing in the background, or to the soundcard, but may have something to do with the way Audacity works with the interface… maybe? Or could the problem be in the interface itself? I don’t know much about these devices; I’ve had mine about 6 or 7 years and never had any difficulties with it before. It seems a simple enough piece of hardware.

Additional thoughts and ideas welcome. I’d love to hear from someone who’s faced and overcome a similar problem. Thanks.

Well, whaddya know. Audacity just decided it liked my audio interface again.

I don’t know how or why, but it’s recording normally now. I don’t know what happened. I re-read a post from last month from someone with the same issue as mine, and the suggested fix was to check the sample rate in Windows Sound settings and make sure that both recording and playback were set at 44100 Hz. So I did this too. Or did it again, as I’m sure I had tried it before. I say that because they were both right at 44100. Further, they must have been set at this for some time because I’ve never done anything actively to change them. Anyway, I thought this was just another wild goose I was chasing, but I started up Audacity again, tried to record something and suddenly it was like nothing was ever wrong. Like I’ve been pulling out my hair the past two months for no reason.

Does Audacity have a “practical joke” setting?

Anyway, thanks to everyone who tried to help, especially the one who helped the other poor soul last month.

I am having the exact same problem with my new computer and my io2 Express. I wish you knew what fixed your issue, because I’m not having any luck.

I stumbled into it. Control Panel > Sound >Manage Audio Devices > Playback (Speakers) > Properties > Advanced > Set Sample Rate to 44100.