I imported a sound track and try to record vocals on a second mono track. However the imported track bleeds to the second recording vocal track. This prevents applying effects to the vocal track. How do I prevent bleeding the first track to the second track?

Large, sealed on the head headphones are required for vocal overdubbing.

Earbud variations don’t work very well.

You need to be recording from a real microphone, not a software device or service. This is a problem if you like to record YouTube or other on-line content. YouTube recording usually requires some sound pathway management and that usually shoots overdubbing in the head. Your recording device needs to be something you can touch and feel. Shure Digital is my analog microphone preamplifier.

It’s a physical thing. SoundFlower is a recording device, too, but it’s software. It’s not a real thing and I can’t reach over and touch it.

Also note that you can’t plug headphones into the computer. They have to go in your microphone, mixer or preamp (see picture above).

Make sure Audacity is not mixing your backing track by accident.

Audacity > Edit > Preferences > Recording. [_] Playthrough should not be selected.


I know the illustration has earbuds. They were convenient for the photo. You still need real headphones for vocal overdubbing.


Hey Guys, thanks for the fast reply. I have not explain everything. I do have a mixer, (2 of them). I have 5 mics, a CAD, 2 MXLs and 2 Shure. The Shure’s are dynamics. I also have a Samson headset to use when recording. I have recorded at least 49 songs and have not experienced this before. But yesterday as I was trying to record a song I notice that the instrumentation was bleeding to the second recording track. By the way I have been using Audacity for a long time and I have the latest version, but I could not figure this one out. Would you suggest a delete and reinstall or perhaps resetting to factory default?

Well I guess Sanju and I are only one’s having this problem.