hi everyone I’m using a mid 2012 13’’ macbook pro core i5 2.5 ghz 8gb ram 500gb hd os x yosimite 10.10.3,along with a numark ns6,serato dj 1.7.5 and audacity 2.1.0.i have followed all the optimization tips from serato to insure my mac is all full performance. when I’m recording my mix everything is fine i have no issues its only when i playback my mix a spike appears in the wave at multiple times and places throughout the entire mix. did anyone have this problem? and if so how did you fix it?

Is the spike regular such as every 6 seconds?

Are you sure the spikes are not clicks on the records?


I’m sure its not clicks on the mp3 and it doesn’t happen every 6 seconds

Set up the Numark USB audio on the Input section of /Applications/Utilities/Audio MIDI Setup with the same sample rate as the project rate you are using bottom left of Audacity. 44100 Hz is usually safest. So that would be 44100.0 Hz 2ch-16 bit in Audio MIDI Setup.

If you still have a problem, Audacity > Preferences… find the Recording section, and reduce the Audio to buffer as low as you can while still making a good recording.

Is there a need to record an already existing MP3?


hi gale i tried to set up the settings you recommended however there is no 4410044100.0 Hz 2ch-16 bit I’m seeing 44100.0 Hz 2ch-32bit integer

Try the 44100.0 2ch-32bit integer, or if there is 44100.0 Hz 2ch-24bit integer you can try that first. The main thing is probably to make the sample rate (44100) the same as Audacity.


thank you gale i was able to create i would say my own midi device from in the midi settings you sent me into so i’m currently working to see if the problem arises

i tried my last setting as in my last message and the problem is still there

Did you reduce Audio to Buffer in Recording Preferences?


hi gale yes i did how low or how high can i set that setting to?

Set it at 0 milliseconds and see if you can record without dropouts. If not, increase it in 10 millisecond increments (10 ms, 20 ms and so on) until you can record without dropouts.