I have set up Audacity with the proper recording and play devices but when i record something from windows, i get nothing but a straight line no indication of any sound waves. I was able to get a recording and a playback earlier but the playback sounded sounded like it was in a tunnel (echoing). Iam using Windows 7.

I think that more information is needed in order to understand the issue.
On this link you will find the answer:

Dig into the set up of your soundcard. Windows 7, by default, sets all sorts of “Enhancements” onto your sound card. You need to find these and turn them off. My system has a Realtek soundcard. I need to go in via the Realtek icon (the red-brown loudspeaker down by the clock), then through Sound manager, to Speakers and into Sound Effects where I need to set Environment to None.

Vince, it can be incredibly frustrating and I hate to say “poke all the buttons and options” on the sound inputs in Audacity, in the Control Panel…it is probably just something with a title that doesn’t look important but actually IS your input source.

If you can post a couple of screen shots or describe your options (sound card? USB adapter? desktop? laptop?) someone may be able to tell you which button to push. But once you get past that–it DOES work as well as anything else you can buy on the market.