Recording with Maya22 USB - latency error [SOLVED]


I have googled, checked the FAQ’s and fiddled with the usual settings as well as reinstalled Audacity and reset preferences - so far to no avail.

I am getting a similar problem to what others have mentioned on this forum but so far the solutions in other threads have not worked for me.

I am trying to record vocals using a Maya 22 USB interface, the project rate matches with the device (44100), When I click record, nothing seemingly happens and then I get that Latency correction error.

When I try to record with just the laptop mic everything works fine, so clearly it’s a problem with the USB device I’m using but I just can’t seem to get it to talk to Audacity.

I am on a Lenovo laptop, running Win 8.1 64 bit. Audacity version is 2.1.2 installed using the .exe. I run a Shure SM58 vocal mic into the XLR input on the Maya 22 and then in Audacity for the input device I select Maya 22 USB channels 1 and 2. (I tried switching to channels 3 and 4, same problem).

Thank you

Step one might be the 48 volt phantom power. Your microphone doesn’t need it and it should be turned off.

Do you hear anything with headphones plugged into the Maya 22?

What does the Signal light do? I can’t get the instructions to talk about it. Many lights turn green and flicker if the volume is about right and then start flashing red if the volume is too high. What does this one do? This is important because if it never comes on at all, it may mean your Maya 22 is broken.

Audacity gets its sound from Windows, not the device. So go into the Windows control panels and see if you get a little bouncing light sound meters at the Maya 22 listing.

One note, Audacity doesn’t easily support ASIO, so everywhere it says “ASIO for this and that,” isn’t going to work for you.


Thanks Koz. I will try turning off the phantom power next time I get a chance.

I hear nothing with the headphones while attempting to record via the Maya. I do get a signal light (blue) shining inside the unit.

I will check the control panel sound meter next time I am recording.

I hear nothing with the headphones while attempting to record via the Maya.

Just so we get the words clear. I want the headphones plugged into the Maya, not plugged into the computer by way of the Maya.

Troubleshooting takes the system step at a time. Audacity is never going to work if Windows can’t find the sound and Windows can’t find it if there’s something wrong with the Maya…and the Maya isn’t going to work with a broken SM58 microphone.

I didn’t start with the microphone because I’ve never been able to break an SM58. One of the music groups tried really hard one night and they gave the microphone back to me in two pieces. When I pushed it back together it was still working.


Thanks again.

OK so the latest is - the 48V power was definitely OFF to begin with, and I have plugged the headphones into the Maya unit - I don’t hear anything.

There are no sound levels at all when I check the control panel sound meters - only an occasional flicker in the built in mic. Weird!

What I AM getting is the green signal light flashing on the Maya itself when I talk into the mic. I have checked the drivers via Device Manager, it says they’re up to date. But the unit may not even be talking to Windows!

OK I’ve got it working now - apparently it was the simplest of fixes!

I plugged the Maya into another USB port! I was using the one on the right side of the laptop, and I changed it to one on the left where there are two ports side by side (one is where I have my mouse). Presto!

Thanks for helping me eliminate the possibilities. Great to have this forum here!

Were the side by side USB ports blue (meaning they are USB 3)?


Hi Gale

Thanks, I will check after I get home.

If you have first-person hands-on experience with particular hardware or devices, that’s gold to us.


Hopefully it may help someone else koz!

So yes, Gale was correct, the USB ports that enabled the Maya unit to work with Audacity are indeed blue in colour.

The one that didn’t work was black (or had a black, er, tongue?).

Thanks again all.

PS: Just an interesting note - when using headphones, I found I had to follow distinct steps to be able to hear myself in real time, with headphones plugged into the Maya unit:

  1. Plug in the Maya unit to the correct USB port (as said above, must have that blue bit inside)
  2. Start Audacity
  3. Only NOW do you plug the headphones into the Maya unit, using a small-large adapter. Otherwise for some reason, the Maya won’t recognise the headphones (even with the correct output selected)
  4. Start Recording, say something to check your levels and you should hear yourself loud and clear thru your headphones.

I consider my problem resolved now.

OK, I will lock the topic and mark it [SOLVED] then. Thank you for following up with answers.