recording with audacity & Mackie Onyx Satellite

Having recently upgraded my computer I have treated myself to a Mackie Onyx Satellite which acts as an audio device attached via firewire. All has installed OK under Vista and I can use the bundled software (Traction) fine but not wanting to embark on yet another learning curve, I of course, want to use audacity. However, while it recognises the device and offers me the option of playing sound via the satellite, audacity will not offer the option of using the onyx satellite as a recording device, even with the onyx powered up andwith an instrument attached before I launch audacity. I’ve updated all the drivers but no joy. Having trawled the forum, I’m still at a loss.

Suggestions anyone?

Thanks in advance for your time.

Have a look in “Edit->Preferences->Audio I/O”
What options do you have available for the “Recording Device”?

That’s what’s been confusing me. Under the recording menu I just get the options for the on-board soundcard;

Microsoft sound mapper (input)
Stereo mix (realtech high definition audio)

Where as for the playback, I get options for the on-board card and the onxy satelllite;

Microsoft sound mapper (output)
Speakers (Mackie Onyx Satellite)
Speakers (realtech high definition audio)

So it’s not like Audacity doesn’t recognise it at all. I’ve tried disabling the on-board sound in case there is a conflict but no joy.

Thanks for getting back to me.

I’m working in the dark here as I do not have a Mackie Onyx Satellite, but this is most likely a driver problem.

Just had a look in the user manual http://www.mackie.com/products/satellite/#DOWNLOADS
It is very important that the drivers are installed EXACTLY as described on page 7 of the manual. If you connected the MOS before loading the drivers, it’s possible that Windows would associate the wrong driver to the hardware - if this is even a possibility you should completely uninstall all drivers relating to the MOS, reboot and reinstall (following the instructions exactly).

The probable reason that Traction works and Audacity does not is that Traction may be using the ASIO drivers. Audacity does not support ASIO due to licensing restrictions.

Mackie say that Audacity is supported, so they should include an alternative (WDM) driver with the software. Their website confirms that this is correct.

You probably know this, but it is very important that everything is connected and switched on in the correct order (see manual for details). Audacity should not be started until all the hardware is up and running (allow a minute for the hardware to initialise before starting Audacity.

There should be a MOS (firewire) recording device listed in “Edit->Preferences->Audio I/O”. This is essential for selecting the MOS as your recording device.

Thanks for taking such trouble to help.

I was pretty careful when installing the card first time around but just in case I did mess up, I did as you suggested and uninstalled everything and started again. Still no joy but then while tinkering I right clicked on the audio icon in the quick-start menu which brought up all devices and, under the ‘recording’ tab the onyx satellite mixer was listed as disabled. I enabled it, restarted audacity and now in the preferences/audio i/o recording menu it offers;

satellite recording mixer (mackie)

Hurrah! One step forward! I thought and selected it but even with this selected, audacity won’t acknowledge the input or let me monitor it. I’ve tried restarting everything and various combinations of inputs on the mackie but still no joy.

Progress though, I really appreciate your help with this, cheers.

LOL, driver problem indeed - audio input disabled by default.

Yes a big step forward. It sounds like you now have the correct recording device selected. Now you need to find the drivers “Control Panel”. Have a look at page 11 of the manual.

Well, after several days of fiddling I’m still no further forward than I was. The mackie seems to only have two changable options, sample frequency and latency. I assume these should be set to the same values in audacity and the mackie but no matter what combinations I’ve tried (which is pretty much all of them!) I can’t get audacity to record. It either pops up an error box telling me to adjust the settings or sets up a new track when the record button is pressed but the cursor sits flashing red and no time sequence is recorded. All very frustrating. I presume I’m into audacity territory here so I’m hoping someone will recognise the symptoms.

Suggestions anyone?

Chris.

Hmmm,

From what I’ve read on the forum regarding Vista, it seems that vista doesn’t support external soundcards if you want to use anything other than ASIO (which you have to for audacity) so I guess I’m reduced to using the software shipped with the mackie until microsoft release service pack 1 for vista. Hey-ho, I can always import the .wav files into audacity once I’ve recorded them. The recorded sound quality from the Mackie certainly is impressive.

If the sample frequency set in Audacity does not match those supported by your hardware you will get an error message telling you to change the settings (there are also other reasons why you might get this message, just to complicate the matter).
If you don’t get the error message, but the cursor just sits flashing as you described, it could well be that this IS a supported setting, but now their is another problem.

If you’ve not given up on it yet, just try going back to the settings that don’t give the error message, and try playing around with the latency settings. I’ve experienced the problem of Audacity not advancing when set to record when the latency setting have been set far too low.

You may actually be correct about Vista, but I think it would be worth checking the above just in case.

Thanks for that,

I have tried adjusting the latency (using the audacity beta version as I couldn’t find where to do this in 1.2.6) for the sampling frequencies that give me a flashing cursor in audacity but still not joy even for latency set to 2048. Under ‘help’ I clicked ‘audio device info’ and get the following;

==============================
Default capture device number: 1
Default playback device number: 4

Device ID: 0
Device name: MME: Microsoft Sound Mapper - Input
Input channels: 2
Output channels: 0
Low Input Latency: 0.200000
Low Output Latency: 0.200000
High Input Latency: 0.400000
High Output Latency: 0.400000
Supported Rates:

Device ID: 1
Device name: MME: Satellite Recording Mixer (Mack
Input channels: 2
Output channels: 0
Low Input Latency: 0.200000
Low Output Latency: 0.200000
High Input Latency: 0.400000
High Output Latency: 0.400000
Supported Rates:

Device ID: 2
Device name: MME: Stereo Mix (Realtek High Defini
Input channels: 2
Output channels: 0
Low Input Latency: 0.200000
Low Output Latency: 0.200000
High Input Latency: 0.400000
High Output Latency: 0.400000
Supported Rates:

Device ID: 3
Device name: MME: Microsoft Sound Mapper - Output
Input channels: 0
Output channels: 2
Low Input Latency: 0.200000
Low Output Latency: 0.200000
High Input Latency: 0.400000
High Output Latency: 0.400000
Supported Rates:
8000
16000
22050
44100
48000
96000

Device ID: 4
Device name: MME: Speakers (Mackie Onyx Satellite
Input channels: 0
Output channels: 6
Low Input Latency: 0.200000
Low Output Latency: 0.200000
High Input Latency: 0.400000
High Output Latency: 0.400000
Supported Rates:
8000
16000
22050
44100
48000
96000

Device ID: 5
Device name: MME: Speakers (Realtek High Definiti
Input channels: 0
Output channels: 2
Low Input Latency: 0.200000
Low Output Latency: 0.200000
High Input Latency: 0.400000
High Output Latency: 0.400000
Supported Rates:
8000
16000
22050
44100
48000
96000

Selected capture device: 1 - MME: Satellite Recording Mixer (Mack
Selected playback device: 4 - MME: Speakers (Mackie Onyx Satellite
Supported Rates: 8000
16000
22050
44100
48000
96000
Unable to open Portmixer

Is it significant that there are no supported rates listed for the MOS?

Too many variables!

Hi, I just bought the onyx satellite and have vista. Apparently there is some way of getting it to work with a third-party driver or something? I can’t get my computer to detect it during the install…Please Help!