Recording with Audacity 2.1.1

I recently upgraded to Audacity 2.1.1 from the 1. 2 version. My problem is i can no longer record from an outboard CD player . previously using the earlier version of Audacity i would plug in CD player to the computer turn it on an dplay thru the computer which told me the computer was receiving the signal. I would then fire up Audacity and then select the track i wanted to record, hit play on the cd player and record on Audacity and volia it would record whatever i wanted. Since installing the new Audacity it will not record when i hit play on cd player and record on Audacity even though i get the playback the recording meters do not change. And on stopping there is no music only hissing. Can anyone tell what settings i need to change on my computer to get the signal into Audacity. Nothing is muted on the computer all settings appear to be the same as previous Audacity Im running Windows 7 with a realtek sound card

Where exactly are you connecting the CD player to the computer? Is it a USB CD player? If not, and you are connecting to the microphone port on the computer, you will likely get terrible quality.

Even with a USB CD player, it’s the wrong approach. Rip the CD track to a WAV file on your computer using CDex or even iTunes or Windows Media Player. If you use CDex, you can even specify an arbitrary time range to rip that is part of a track. Then import the WAV into Audacity. That way you get a perfect copy of the audio.

If you must record the CD, do Transport > Rescan Audio Devices in Audacity then choose the input the CD is connected to in Audacity’s Device Toolbar. If you are connecting to the mic port (or better, the line-in) on the computer, you may need first to enable that input in Windows Sound.


Assuming you are connected to line-in on your soundcard, make sure you’ve selected line-in as your [u]Recording Device/Input[/u].

Nevermind… I didn’t read carefully. Like Gale says, don’t “record” from a CD player.

Unless, that is, you have one of those wretched CDs that were sold a few years back with DRM copy protection on them … :smiling_imp:


Legality aside, there are several ways to get around that. Generally speaking, dBpoweramp can rip protected CD’s using its “Defective by Design” mode.

ISO applications that can see the first and second CD “sessions” separately will let you extract the audio that is in the first session.

Or you can mount the CD in some software as a “virtual drive” which then appears to the computer as a “normal” CD without protection.


Thanks everyone for your suggestions and help. Yes i did use the rip method with some great results. The thing is i sometimes use the cd player/ tape player to do Cds for folks. The CD i can work around the tape player i cannot. As i stated in my post the only thing i changed was updating Audacity to the newer 2.1.1 version. So obviously theres something in the newer version that was not in the older version which is now preventing the Program from receiving the signal to record. And yes ive always used the line in as well. I know its something simple that needs to be changed but right now im at a loss to know what it is

Audacity records the input signal you point it to. If you point it to an input that is not the input you are recording from then you will only record noise and hiss.

So choose the line-in input as the recording device in Audacity’s Device Toolbar.

If you do not see the line-in listed, Transport > Rescan Audio Devices in Audacity.

If you still don’t see the line-in listed in Audacity, open Windows Sound and follow the instructions in the link to make sure that the line-in is displayed and then enabled.