Recording Volume hum with update

I updated to 2.1.0 with the installer last week. I have a very loud hum when I record. All I did was update. I didn’t change any volume settings or equipment. I had no problem before.

Noise (including hum) is an analog problem…

What are you recording? A USB microphone? An analog computer microphone? Something plugged-into line-in? Streaming audio? Something else? What kind of hardware you using and how are you connected?

Is this low-frequency power line hum, or more of a high-frequency whine?

I have a very loud hum

How bad is it in dB, or the “size” of the waveform?

I have a Sansom CL7 mic connected to an M-Audio box. I have used this set up for over 5 years. I have attached a short sample of the sound or recording nothing. 41000 mhz 32 bit.

It’s fixed! I apologize to Audacity - it wasn’t your update. I had re plugged all my equipment to try to fix it, but I hadn’t done the connection between the mic and cable - only the mic cable to the M-Audio. I finally re did that one and it worked!
Thanks to all who downloaded my file and tried to help. I have attached a new file. Let me know if you think it’s gone. It sounds good to me.