Recording vocals

Hi, I am trying to record vocals while listening to an instrumental. I have the instrumental in track 1 and using track 2 for my vocals. However, when I hit record the instrumentals start recording in track 2 along with my vocals. I tried turning overdub off but then I can’t hear the instrumentals. How do I solve this issue?

That’s what happens when you tell Audacity to record Everything On The Computer (Stereo Mix) instead of just the Microphone. Change that in the Audacity Device Toolbar.

Audacity Recording options should only have Overdubbing selected.

I predict… Your next complaint is going to be you can’t hear yourself right during the overdubbing performance and the “Latency” correction doesn’t work. Correct. Unless you’re using the special-purpose hardware or software we talked about in the tutorial, your own live voice is always going to be late or have an echo. The show will be perfect, you just can’t hear yourself while you’re making it.