recording vocals from mixer

I am using the current version… just downloaded tonight… already navigating everything pretty well but I expect to get a lot better.
I am going from a PA MIXER into the audio in on the back of the pc using WINDOWS 7.
I am trying to lay down vocals to existing music from my ITUNES… all is fine with that but…my VOCALS are sounding layered? / echoed? / delayed?
When I am singing along with the music I hear myself but there is a kind of “another” one of my vocals going along with it sounding like an EFFECT… It is impossible to sing this way as it is blatant and throws off my TIMING… As far as the HEADPHONES i plug them in to the headphone jack on the PC and or the jack on the external speakers and it sounds the same… i thought maybe it was coming from my PA MIXER but when i plug headphones into that devise there is no EFFECT? I WOULD THINK this is not a serious problem but i can not find the solution right now and hope someone can tell me an easy answer… I READ lots of the posts and found info on LATENCY but my problem does not really sound like a LATENCY problem since the EFFECT i am getting really almost does sound like two singers… ONE BEING IN TIME WITH THE MUSIC AND ONE DELAYED… Maybe I am wrong and it is latency but am hoping someone can help…
ONE NOTE THOUGH…THAT MIGHT MAKE IT LATENCY is when i turn AUDACTIY off … my MIC VIA THE PA still gets sound and the sound is still with the same problem so maybe its in my PC? I looked at functions there as well but got lost lol… HELP and ty… im looking forward to laying down some serious tracks for some very pro interesting bands and hope THIS PROBLEM gets solved quickly

Ensure Transport > Software Playthrough is off (not ticked or checked) in Audacity.

Given you are hearing the problem when Audacity is quit, you have probably enabled “Listen to this device” in Windows. Right-click over the speaker icon by the system clock, then choose “Recording Devices”. Right-click over the computer input that you are singing into then choose “Properties”. Then click the “Listen” tab and remove the tick (checkmark) from “Listen to this device”. Then OK and OK.


so I did what you said… but when i did so… all SOUND was deleted from headphones/speakers… i can see music and MY VOICE in the meter levels so it is and was recording/playing but i could not hear it?
So I re-clicked the sounds icon and well… i sang a rough track with the headphones HALF ON MY SKULL so i could hear my voice without too much of that weird dbl vocal in the head phones… when i play back the recording and mute the music my voice sounds fine so it is recording normal… i just need to somehow FIX the monitoring/headphone mix so i can really belt out the songs for real… anyways… anymore advise is greatly appreciated

What do you expect? You said you did not want the recording sent to the computer output.

Why don’t you monitor the input in the mixer and choose the mixer as the Audacity playback device? I thought you were doing that already, hence why “Listen to this device” gave you a delayed copy of what you were singing.

Is it a USB Mixer? What is the make and model number of the mixer?


it is a Yamaha mg16/6fx it is my live rehearsal mixer… its a little much for doing what im doing… OVERKILL but it is a mixer and does work I will try and go out from the pc into the mixer and use the headphone mix on MIXER and see what happens… off to radio shack for more cables lol… I will keep you posted

You could also use something like the Behringer UCA202 USB interface to sit between your mixer and the computer. Monitor in the mixer, send the master mixer output to the UCA and set the UCA as Audacity’s playback and recording device.