Recording Vinyl Into Audacity 'Skips'

I’ve linked a toslink cable from the optical output of my Linn Akurate DSM directly into the built-in input of my late 2011 MacBook Pro to digitize some vinyl albums that aren’t available on CD. The vinyl is played on a Linn LP12 into the Akurate DSM.

The MacBook Pro is running El Capitan 10.11.6 and Audacity is 2.1.2 build date 12 Jan 2016 commit id 53b8fd5.

Sometimes the recording ‘skips’ a few seconds randomly. It’s definitely NOT the vinyl; I monitored the recordings and the music sounded fine.

An album I tried earlier today plays back on Audacity (before any editing etc.) fine for about 2 mins then I hear a 1-2 sec ‘skip’. This randomly repeats. So at the end of that side of the album the Audio Position at the bottom of the screen correctly shows 27m 41 secs BUT the graph showing the wave across the screen ends at 25m 29s. So with various random ‘skips’ over 2 mins has been lost over the album side.

I’ve attached a screen grab during the recording which already shows a mis-match between the Audio Position (correct) and the time on the wave graph (wrong).

I am totally lost as to what might be causing this. Other than the ‘skips’ the recording sounds great.

Any ideas?!?!?
Audacity Lost Time Skipping Screen Grab.jpg

See if there’s anything in here.

Keep reading even if it seems the document is going off on the wrong direction.


Also try this

but note that is our work-in-progress Manual for the next release of Audacity, so don’t otherwise use that as your help document.


Thanks so much for you prompt help guys!

However, I seem to have taken one step forward and one step back.

Having read the new FAQ that you pointed me at, I have turned off both View>Show Clipping and also Transport>Software Playthough (I did not increase the default Audio To Buffer=100 in preferences as I didn’t know what to set it to).

I tried the same album again and… I ended up with a recording of 51 minutes that matched the album length! W H O O H O O! :smiley:

Problem solved… or so I thought! When I started splitting the album into tracks I discovered a buzz / distortion appears on most of the the recording. :frowning:

  • It’s not that the music itself that is distorting; this noise is there as well.

  • It’s not clipping; it’s not an ultra loud album and the feed is optical directly from the Linn ADSM.

  • It starts at a random point but fairly soon in the recording; on the first pass its started around 4m, on the second attempt at around 2m30s on the third attempt it didn’t start until around 5m30s.

  • Once it starts it stays there for the remainder of the album. Prior to it kicking in all 3 attempts sound great.

Any ideas why this has started happening?

I note this from the online Manual for your Linn Akurate DSM

Ideally, integrated amplifiers or power amplifiers should not be located directly above or adjacent to other heat-producing products such as radiators, other power amplifiers, etc. If multiple amplifiers are being used and space is restricted, placing
them side by side is preferable to stacking.

It is advisable to site your product away from (and if possible connected to a power socket on a different circuit from) powerful electrical or electronic products such as TV sets, computers, cookers, fridges etc. This will prevent the possibility of the strong electrical and electromagnetic emissions or interference given off by such devices adversely affecting the performance of your amplifier.

Can we assume you have all that covered :question:

Nice looking piece of kit by the way :sunglasses:

Oh and nearby mobile or transportable phones can also cause interference.


Also have you disabled WiFi while you are recording?


Hi, all. This is my first post. I’m bumping this thread because I’ve been enduring the same problem with no luck. Every time I try ripping either side of Aoxomoxoa for archiving (32 bit float/44.1), snatches of the audio are missing upon playback.

I’m running Audacity 2.1.2 on a MacBook Pro w/ El Capitan version 10.11.5. I’ve got plenty of RAM and processing power.

“Show clipping” is unchecked. “Overdub”, “hardware playthrough”, and “software playthrough” are all unchecked.
“Audio to buffer” is set at 100 milliseconds. “Latency correction” is set to -130 milliseconds.
“Sound activated recording” is unchecked.
“Update display while recording” is unchecked.
Under “Audio MIDI Setup” built-in microphone, built-in output, and USB AUDIO CODEC are all set to 44.1kHz/2ch-16bit integer.

I have attempted the vinyl rip with my stereo unconnected, with wifi off and all other applications closed, as well as following a clean CPU reboot. Still I get wonky rips and jerky playback.

I’m using an AT-LP120-USB. Nothing fancy but has gotten the job done in the past. I noticed this problem since I got this computer a couple of months ago, and this is the first time I’ve really tried concentrating on a rip since then. It’s frustrating.

Please let me know what you think is amiss! I’d really appreciate it.

Many thanks…

That’s probably too high. See previous posts and but note that is our work-in-progress Manual for the next release of Audacity, so don’t otherwise use that as your help document. Look especially at AppNap and Antipop.

See also

Does GarageBand have the same issue if you use that for recording?

You could update to current OS X 10.11.6. It might help.


Thanks, Gale. Is there a ballpark on the lower end of audio buffer that you can recommend, rather than working up 10 milliseconds from zero for each LP side I rip? (FWIW I tested a couple of 45s and there didn’t seem to be an issue, so the length might have something to do with it.)

I’ve updated the OS as suggested, and set to prevent the OS “app nap.” Hopefully that had something to do with it. I’m already running Audacity with everything else closed on a clean reboot and with wifi turned off, so CPU power and priority shouldn’t be an issue.

I’ll try ripping a fresh record sometime this evening and see how it works out. If the issue persists I’ll see what happens in GarageBand and report back.

Thanks again for the help.

No. The Audacity buffer length is interdependent with the buffer of the device you are recording from, so it’s best to work upwards from zero as suggested.


I’ve tried recording the same album again (Mike Rutherford’s Smallcreep’s Day) several more times making sure wifi was turned off and iPhone was nowhere near any kit or cables.

I STILL get that buzz appearing after between 2 and 6 mins into the recording all the way to end. As I said before it’s not the music that’s distorting; it’s a buzz/distortion that’s there as well as the music.

I’ve tried exactly the same album/set-up with VinylStudio… no such problems!

So it must be something in Audacity. Should I try lowering the default 100 setting on AUDIO TO BUFFER?

You can export a few seconds of the buzzy recording as WAV and attach it so we can hear what it sounds like. Please see here for how to attach files:

The default 100 setting of Audio to buffer should be reduced to zero then increased if necessary in 10 millisecond increments. But if it is a buzz, it probably isn’t related to Audio to buffer.

You could try recording at 44100 Hz (bottom left of Audacity) instead of 96000 Hz, and set 44100 Hz for the built-in input in /Applications/Utilities/Audio MIDI Setup. Or at least, set Audacity Project Rate to the same sample rate you see in Audio MIDI Setup.


Hi Gale & all.

I’ve carried out some more tests, but achieved very little.

I completely re-installed Audacity (from your website), restarted my MacBook Pro and tried the same album (still at 96k) with the Audio To Buffer at different values… the results are very random!

  1. Audio To Buffer 50 buzz starts at approx 20s into recording
  2. Audio To Buffer 100 buzz starts at approx 59s into recording
  3. Audio To Buffer 150 buzz starts at approx 3m 35s into recording
  4. Audio To Buffer 200 buzz starts at approx 1m 10s into recording

I’ve attached a clip from the 4th run. The clip comes from around 1m10s in as the distortion/buzz creeps in and would then stay for the rest of that side of the record.

Any suggestions would be very gratefully received as I am baffled! :wink:

I believe the buzzing arises from frequent small dropouts, not electrical interference. It can sometimes sound more like “clicking”.

It’s commonly reported that the disturbance only starts some way into the recording.

Audio to buffer, disabling AppNap, using AntiPop, matching sample rates in Audio MIDI Setup (or all four) almost always work.

Please try what I suggested about sample rates:


Thanks Gale; I’ll try those out as soon as I have time!