Recording System Sounds

  • Manjaro Linux 18.0.2
  • Audacity 2.2.2
  • Distribution’s release

Hi,

I am attempting to record audio output from LMMS, Hydrogen, etc. using Audacity. However I am having some difficulty with the configuration. When I select the Preferences \ Devices \ Recording \ Device option I am presented with a long list of options including ones for pulse audio. I’ve tried all the default and pulse audio options but when I start recording, there’s no waveform, no recording takes place. Just wondering how I might approach fixing this.
Any help would be much appreciated.

Thank you

LMMS and Hydrogen are often used with Jack audio system. Are you using Jack audio system?

Hi,

Thank you for your response. I tried experimenting with QjackCtl and LLMS and Audacity but when I press play on Qjack, the audio from LMMS cuts out.

Also, I don’t seen an option to select JACK from the recording devices option in Audacity, whereas, Pulse audio is listed as an option.

Thank you

Jack should be started before launching the audio applications that will use it.
It is sometimes necessary to tweak the setting in QjackCtl in order for Jack to run smoothly, so the first step is to experiment with QjackCtl and get Jack running reliably.

The order to start the programs is:

  1. Start Jack (via QjackCtl)
  2. Start Hydrogen / LMMS / any other audio applications
  3. Start Audacity

Once Jack is running, “Jack Audio System” will appear as an option for the “host” setting in the device toolbar.

The reason for starting Audacity last is so that Audacity can see the other applications, then you can select the application as the recording input.
In this screenshot I am selecting Hydrogen as the recording source:

jack.png