recording streamed music using Audacity

I’m following the instructions for recording using WASAPI, but once I press ‘record’ two red arrows appear over the 'audio track’window.was working perfectly on windows 7…is it a problem on windows 10? can any one advise???

Please save the “audio device info”, and attach the file to your reply.

You need to start streaming through your speakers or headphones first. Actual recording will start automatically when streaming goes through.

Thanks Robert2, tried that , the track opens, but two little red arrows appear and nothing happens.
Steve…is t
deviceinfo.txt (6.02 KB)
his the file you mean??..

Yes, that’s it.

As a test, try:

  1. If Audacity is running, quit and restart Audacity.
  2. Set the “Project Rate” (lower left corner of main Audacity window) to 48000.
  3. Start an application (such as your web browser) playing.
  4. Click the Record button in Audacity.

Thanks Steve…no joy I’m afraid…gonna try to attach a screen-print…
Doc1.pdf (366 KB)

Is this your first time running Audacity on this computer with Windows 10, or have you previously recorded anything with Audacity on this computer with Windows 10?

records perfectly using a usb microphone, it will actually record the streamed music using the MME setting but the sound is crap…

That’s probably recording using the built-in mic (I’m guessing this is a laptop computer?)

no, its a desktop actually…

Interesting - so how exactly did you manage to record sound playing on the computer with MME? Was your USB mic plugged in? Does your computer have a built-in mic? Does the Windows Sound settings offer a “Stereo Mix” option?

no Steve, didnt have the mic in…think its recording via a webcam. i’. really trying to figure out how to get the WASAPI working again…

That’s strange, because I don’t see a webcam listed in the Audio Device Info. Did you disconnect the webcam at some point?

“Again”? As in; “again on this computer”, or as in “like I did on my old computer”?

There’s something peculiar with your computer, otherwise it would work like it does for (almost) everyone else. The tricky part is working out what is peculiar about it, which is why I’m asking for clear and detailed information.

thanks for your patience Steve…I was running on a different computer which was operating on Windows 7, and the problem came with a new computer using Windows 10………….

Hey, Good news…………got it working by a process of elimination………thanks for helpful suggestions

Excellent news. What fixed it for you?