Recording stops short

I have a new Kubuntu system and with it, Audacity 2.0.5. I have just tried to
use it to digitise from a USB input. First time I tried, it stopped after about
50 min. Then I tried to set the length at the bottom of the window to 20 hours,
and it seemed to go on to almost the full 60 min of the cassette tape I was
digitising, but it still stopped closer to the end.

what should I be setting to make it go the whole length?

What is the make and model number of the USB device?

Don’t make any selection in the blue waves or Selection Toolbar then recording should carry on until you press Stop.

However USB device streams can fail after a while due to bandwidth constraints. Make sure you are using an empty USB port and not a USB hub. Reboot the computer.

Use 44100 Hz project rate bottom left of Audacity (extreme high rates could fail). Look in Edit > Preferences then “Directories” and make sure you have plenty of disk space on the drive.


Thanks. I use a Behringer U-CONTROL UCA222 device, which I feel sure works.
At the bottom right of the Audacity window, the second from the right says End or
Length. The second of these is activated. Are you saying I should not set anything
in that little number window?

PS: I posted the question again, because I thought I had not sent the first one off
properly. Sorry.

I suggest you follow the advice to reboot the computer and use 44100 Hz project rate.

If you just launch Audacity then press Record, there will be no selection present and so the recording will not be constrained by the selection length, it should continue until you press Stop.

If you will not be present when the recording ends, you can set the recording length using Timer Record or by making a selection that is the required recording length. See Can I set Audacity to record at a certain time?.

OK I deleted that duplicate post.