Recording stops, happens with cracks and hiccups,

I upgraded to Ubuntu 12.04, with new Audacity and since then recording is impossible.
I’m recording from a turn-table connected to teh PC via a USB pre-amp.
When recording:

  • Recording starts and then get a hiccup and stops.
  • Nothing happens.
  • record but with lots of clicks missing bits and peaces, …

Ive tried all kind of settings, even complet reinstall, but it remains always the same.
Searching for a solution I looked in teh log file and found hundred of lines like this.
Error: Failed to get file system statistics (error 2: No such file or directory

Is it possibl ethat this is the issue?
When yes, how can I solve this?

Many thanks in advance,

This error almost always happens when the computer is too busy to manage real-time sound. We wrote a couple of things about this.

There are two information branches and they’re both valuable.

If you’ve never done real time audio or video before, it’s stunning how quickly they will reduce a slow or underresourced computer to trash. It’s recording the piano C note and if it isn’t ready for the following G note at exactly the right time, the music will fail. It’s not like recalculating spreadsheets where you can go to the Tesco or 7Eleven while it’s calculating.


Is the USB preamp going through a hub with other things? That’s a classic problem with USB sound and is related to equipment being too busy for live sound.


Thanks for the tips.
I’ve read these comments and guides an tried them without any success.

The PC is a DELL Latitude E6200.
Ubuntu 12.04, 64-bit version.

When running Audacity, nothing else is running on the PC.
The USB port is a USB port on the PC, no hub.

I’ve been using Ubuntu 10.04LTS with an older version of Audacity for months, recording all my LPs, without any problem.


If you are recording with Transport > Software Playthrough checked, try unchecking it.



I wil try it, but is it not the purpose that while recording from a turntable you can hear what’s going on?
Turning off “Software Playtrough” just stopss any control on what’s recording at that moment.

Why was it working perfectly on teh same machine with Ubuntu 10.04 LTS 32-bit and an older Audacity?
This seems odd. Newer should be better and not worse or like Microsoft “A new software version means buy a new PC”.

Yes you won’t be able to hear what you are recording if you uncheck “software playthrough”. You can still monitor the level visually by clicking in the recording meter.

Unchecking software playthrough is just the first thing to try. Another would be not to use ambitious project rates like 96000 Hz (not that I know you are doing that).


Turning off software playthrough and lowering the sample frequency gave now results using USB.
I connected the truntable directly to the audio line in and connected hardware ground of turntable and PC to remove noise.
with software playthrough off it works now perfectly.

Thanks for all the hints!


So what project rate are you using now? It ought to work OK at 44100 Hz or 48000 Hz.

Do you mean without using the USB pre-amp? The USB pre-amp will presumably provide RIAA equalization as well as amplification.