Recording Stops For No Reason?

For some reason lost to me, Audacity is stopping at random during recording. I’m using the 2.0.6 version with Windows 7, a Carvin sound board, and a USB cord. As far as I know, the connections are fine. Sometimes, it’s able to complete a recording session (a bit over an hour) without issues. More frequently, however, it will cut off after 15-20 minutes and sometimes after only a few minutes. This results in the session being broken up into 2-5 parts with time between missing. It does not, of course, resume on it’s own. I’ve been using Audacity for a few years and this problem only surfaced last year. If you have any ideas what may be the source of the issue, please let me know. Your input will be greatly appreciated. Thanks in advance!

What is the model number of the Carvin - is it a USB mixer and is that all you have in your audio chain? And what actual audio are you recording?

USB streams stopping is usually due to lack of computer resources are perhaps to a wrongly set buffer. So try shutting down un-necessary apps, or rebooting the computer, and look in the Recording section of Audacity preferences at “Audio to buffer”. The default is 100 milliseconds, but depending what you are doing, you could try increasing that value.


If there is a time selection (see: then recording will (by default) stop at the end of the selection.
To ensure that there is no selection, click the

“Skip to Start” button before you press the Record button.

I presume this is a stand-alone computer, not on a network?

Are you doing anything else on the computer while the recording is taking place?

Relevant to that (assuming you are not recording into an already saved project), use Edit > Preferences… , look in the “Directories” section, then tell us the path it says in the “Location” box.

The Audacity temporary folder should be set to a fast local drive with plenty of space, that you have permanent permission to write to.


Thanks for the questions. The Carvin is an analog mixer with a USB output. The audio being recorded is from microphones and instruments during a church service. There seems to be plenty of space on the HD and no other apps are running when the computer is recording. I’ve done disk defrags, cleared old files off the HD, and run other system checks and maintenance. I’ve tried rebooting the computer, of course, but the problem persists. I am not at that computer right now, so I don’t know what the buffering is set at. We have tried installing a fresh copy of Audacity as well. The recording is a new project, not continuing into a saved one. I don’t have the exact path, but there is only one HD on the computer and no network drives.

If you do that, make sure you check (tick) the box “Reset Preferences” halfway through the installer then you can start from factory fresh Audacity settings which include 44100 Hz project rate. If you are using much higher rates it won’t help your problem.

Does this mixer have a software control panel with sample rate and buffer settings of its own? If so, look in there too. Sample rates when chosen should be the same everywhere, including in Windows “Sound”.

What host are you choosing in Audacity’s Device Toolbar? Resetting Preferences will set you back to MME host.