Recording stops after 10 - 30 seconds

I have a problem with recording our band rehearsals. The last 2 weeks I have been getting an error message box and the recording stops. A box comes up and says
“competing Program - close competing program” - I have nothing else running at the time of recording
There was 2 other messages but I cannot remember what they were.
Last week I had read in trouble shooting to try shutting down the computer and restarting the computer. I tried that and it seemed to solve the problem. I recorded 4 tracks of just me and my guitar and it worked, fine. At rehearsal last night, the same problem came up in our first song. I shut everything down, restarted the computer and tried again. The recording lasted about 35 seconds and stopped. I shut down and restarted again down and restarted again and this time it lasted for 5 songs before it stopped recording. I shut down and restarted again and this time the recording lasted for 7 seconds, I hit record again and it started again but only lasted another 7 seconds. (I gave up after that as the other band members were getting upset)
When the recording stops, the line extends down into the lower track space. There is a small box with what looks to be a clock face and the number 1 beside it.
I have tried again this morning but cannot get it to do this again. I have tried 6 times for recording times of 3 - 5 min each. I wish I had taken a picture of the screen so I would remember what the dialog box said. This morning the first 2 recordings I did were fine, the next 4 had hardly any volume on the recording line although the recording indicator was registering correct recording levels and the microphone volume level was almost all the way to the right. In order to get volume out of the recording I had to go into “effects” and press on loudness normalization in order to get any volume out of the recording. Can you help with this? is there a glitch in the system some where? Thank you, Bruce

I don’t recognise that message. Could it have been:

Recorded audio was lost at the labeled locations. Possible causes:
Other applications are competing with Audacity for processor time.
You are saving directly to a slow external storage device.

That looks about right.
First statement is correct - lost at labeled location
Second statement - I have no other programs open at the time of recording.
Third statement - I am just recording each track on Audacity and then I transfer them to an MP3 file and save that to the desktop. I then delete the Audacity file. I am saving it to the computer hard drive via an MP3 file. The computer has a 1 TB hard drive and I have used a total of about 10% so there is lots of room. When it was recording, at the bottom it said I have 5 - 6 hours of recording time.

I checked my computer again, I had 2 saved Audacity projects on the desk top. Could that have been causing the problem? All this seems to have started after they were saved to the desktop.

That’s not much. That’s only about 7 GB. Does your computer have more than one hard drive?

Hi. Sorry, I just tried recording something and it said 1497 hours of recording time.

Hi again. Is it possible that recording by myself is fine for the program but when the band is together it is overloading the program. We are not overly loud, We play classic rock so we are not pounding on the drums or guitars. I try to keep the record level just under -6 and sometimes it goes up tp 0. Then I start to get clipping.