Recording problem

After importing a stereo track, it records the stereo track onto the new track. How do I fix this?

By default Audacity always creates a new track when you click the Record button.

To get Audacity to record onto an existing track, use Append Record : Shift-click on the record button, or press SHIFT+R.
– Bill

Yes I know, but it is recording the stereo track I have imported on channel 1 as well.
I just want to record my guitar on the new track.
Is this something to do with the settings?

Set the recording input in the device toolbar to the input that you are actually using and NOT to “Stereo Mix” or “What U Hear” or “Microsoft Sound Mapper”.