recording/playback problem

i tried to record a song while playing the karaoke track.
here’s the problem:
when there is no playback, or the sound stops in the song, my voice sounds clear. but as soon as the sound starts again, my voice fades away.
i also believe that my mic is taking input from the file. even when i’m not singing, the mic meter shows activity.
please help. i need to send my recording to a lot of universities; so this is urgent :frowning:
any help would be greatly appreciated
problem.aup (15.8 KB)

I assume you are on Windows Vista or later, please tell us what version of Windows you have if not.

Most likely Windows is applying effects. See here for how to correct it in Windows “Sound”: .

While you are in “Sound”, choose the “Communications” tab if you see it. Under “When Windows detects communications activity:”, choose “Do nothing”.

Have you listened to the recording to see if that’s the case? If you are using a cheap mic it may have a high noise level.

To make sure you are recording only your mic, wear headphones then open Device Toolbar and set the third (input) box to your mic, not to stereo mix.

By the way the AUP is nothing but a text file pointing to the audio data. We can’t hear anything when you attach the AUP. Please see: How do I save my audio for use in other programs? Does saving a project (AUP file) do that? .


i have windows 7 and my audacity version is 2.0.5
in the communications tab, it’s already set to “do nothing”
so i have done everything but it’s still the same.
as soon as the music starts, the bars in the monitor bar go to maximum and are not affected by my voice.
sorry for leaving out these details. i have also attached the mp3 file now.

Have you followed the instructions to turn off enhancements? This is separate from the Communications tab.

Where are you playing the file that has the song? The best place to play the file is in Audacity. Then set Transport > Overdub on so that it is ticked, and set the Device Toolbar input to the microphone you are singing into. Then as long as you wear headphones you should record only your voice.


i have checked the enhancements.
i am already playing in audacity.
the problem is that as soon as the music comes in, i have to literally scream into the mic

Please follow the instructions. Turn off all enhancements or sound effects (go into the control panel for the sound card and turn them off there too).

Turn off Skype and all VoIP programs.

Record from your mic, not from stereo mix. Please confirm exactly the input device you are recording from in Device Toolbar (name, make and model number).

Please confirm exactly the device you are using for playback (name, make and model number).

It is best to use the same device (for example, built-in sound card) for both playback and recording.

Make sure the playback and recording devices have correct drivers made by the device or motherboard manufacturer. Please see .

Wear headphones.