Recording over imported track not working

Does it work if you disable “Hear other tracks during recording” in Transport → Transport Options?