Recording on the Same Track Over and Over Again

Newbie here so please be gentle …

I am correcting my English/Spanish accent so I need to record and hear my own voices over and over again, but each time I click the record button, it automatically starts a new track. Right now I have to use “delete tracks” to clear tracks after each recording, but there gotta be a better way to do this. How can I change my settings so it will record over the same track not starting a new one?

I am using the latest Audacity 2.01 on Windows 7. I’ve googled and read the FAQ but can’t find my answer. You guys are my only hope.


Press Ctrl+Z before you start recording the new track. That will “Undo” the previous record.
Tip: Pressing “R” will start recording. Spacebar will start or stop playback (and can also stop recording).


thanks for the reply. yes, “ctrl-Z” will do the trick.

muchas gracias !