Recording on IMac

This is the first time that I am trying to record on my computer using Audacity 2.0.3, from my keyboard, I can not get recorded.
I have downloaded Core Audio, Lame,Soundflower(2Ch), and per suggestions read on this forum I have purchased Behringer UCA 202.
The setting that I have selected is “Core Audio”, “Builtin Output”, and for input “Soundflower(2ch)”, and “stereo input”.
I have read all the Tutorials regarding recording and have followed their suggestions, but still no recording.
I know this may be basic for most of you but it is new for me and I need your help, PLEASE.

What are you trying to record? Sound playing on the computer? Sound from some external device such as a cassette or turntable? From an external microphone? From the internal microphone?

What model of iMac do you have? From your description is seems to have a built-in stereo input.

Soundflower is for recording the sound playing on your computer.

The UCA-202 is for recording from an external device.

LAME is for exporting MP3 files of your recordings.

– Bill

Thanks Bill
I have IMAC 10.6.8, & I am trying recording from an external source, my keyboard.

As far as I recall, all iMacs still have a 1/8" line level input jack. What output are you using from the keyboard?

This manual page may help:

– Bill

Hi Bill
My connections are fine I am using an RCA jack connection to the Musical Keyboard output line, and the 1/8 jack to the computer, now here I have 2 choices, the earphone or one other, I can also connect to the computer via Behringer and the USB Port. I think my problem is the settings on the Audacity and their combination with sound settings on the computer. Thanks for your help.

Use the “other” 1/8" input on the iMac. The symbol is a circle with two inward-pointing arrows.
See the illustration on this page:

In Audacity, on the Device Toolbar ( )
select “Built-in Input” or “Line Input” or similar.

More details about selecting the recording input in Audacity can be found on this manual page:

To hear what you are doing, check the Transport menu and make sure that Software Playthrough is checked.

– Bill