recording... not working

last time I used Audacity to record, all worked fine

today, the options for microphone and speakers are grayed and the drop list does not work
“pressing” record button does not work
I downloaded the new version 2.3.0, same problem
windows 7…

playback volume selector moves but record level selector does not
I’ve checked and it looks like the microphone is connected…

I found a way to test the microphone when I had a problem some years ago, but don’t remember how that was done and, can’t find notes on it

I guess I can’t up load screen shots?

thank you…

I tried importing a recording from my files, the file was imported to the audacity window but a white “NO” symbol appears when i tried to play or edit it

the original… not sure what is is called, the window of the new audio track, I can’t delete it… when I click the X, says “esc to cancel” on bottom bar

I can’t delete the one I imported either

I tried “importing recent files” thinking, a file I used recently… it won’t play

baffled…

just tried, it, when audacity opened I could see the “microphone”
was not gray… when I selected “record” nothing happened and “microphone” went gray.

I closed and re opened audacity… and chose MME from the drop list, now it records…

it works but I am still baffled
why did the setting change and why was is grayed out before?

Perhaps not plugged in all the way?

If it’s a USB mic, perhaps Windows failed to connect it when you booted up, or if you’ve not rebooted for a long time, Windows may have turned it off (frequently happens with USB devices if Windows goes to sleep - rebooting usually fixes this).

Note that when connecting an audio device / microphone, you should do that before starting Audacity.