Recording not keeping up with Tape


I have just loaded Audacity 2.0.1 to my Debian Wheezy system. I have a ezcap Super USB Cassette Capture Device and it is sending and Audacity is receiving but it is doing so in chunks. That is, the tape is playing quite happily but Audacity is only capturing chincks of 10 to 15 seconds with 10 to 20 seconds or more between chunks. The recording shows as continuous but when you play the tune it will play 10 seconds or so then jump to the next chunk.

From my “limited” reading of other threads, I have made sure all other options under Transport are turned off but it is still the same.

The PC has good Mhz and pleanty of disk space and 4Gb Ram.


Are you going through a USB hub? Audio doesn’t like that.

What else is the computer doing? What’s “plenty” of disk space?

Audio (and video) production are computer stressors. Both happen in very real time. The computer can’t go off and do housekeeping during a song. The next musical note is going to arrive right now and the system has to be ready for it. It’s not like recalculating a spreadsheet where you just go for coffee and check your email until it gets done.


Plugged direct into one of 5 USB ports on the back of the Machine. No Hub.
446Gb Free
I did have Iceberg open and was playing Solitaire, so not really stressing it.

I have run the same equipment and program on Win 7 with a lot more going in the background and only 2Gb Ram and it was fine.


Any game stresses the computer.

If it is a recording problem, double-check there are no checkmarks (no ticks) in the Transport Menu.

Try another USB cable.

Open the Audacity preferences, Recording section, and try increasing “Audio to buffer”.

If it’s a playback problem, leave “Audio to buffer” at 100 ms. Quit Audacity and reboot. Open a terminal and type

env PULSE_LATENCY_MSEC=30 audacity