recording noise persists

My laptop sound out worked with media player prior to install. Installed AC 2.x.x on Win 7. Can record but no output. Selected playthough, clicked to start playback. Selected all devices shown and keep getting error opening sound device. The output I recorded did start once but no sound output so I select another device from the list trying all one at a time. After that went back to original setup but get error opening device. When I exited Audacity the media player will not output sound. I do get error beeps out but no sound. Tried ClearFI same result. New to posting, new to Audacity. Help/suggestions much appreciated. Am sorry if posted to incorrect location. Thanks for any help.

Split to new topic.

I’m unclear what your question is.
Is the topic title relevant?

What is "AC 2.x.x "

You can record what?

What is the exact message? Does it mention recording or playback devices?

How do you mean “output started but no sound”?

What does that mean?

I just joined so I do not know nor can see a means to start a thread or ask for help with my problem. I tried to explain details so here goes again.
My operating system is Win 7 (put on old laptop to see if program worked before installing on final platform)
AC 2.x.x is Audacity ver 2.x.x so it is the newer version
I recorded audio but the recorded audio does not play - cannot hear sound
error code is “error opening sound device”
tried Windows Media player and now it does not work after installing Audacity ver 2.x.x
before it worked fine. Also tried another audio player which worked before the Audacity install but it does not work either after the install.
I truly am sorry for “barging” into this topic/thread but I could not find a way to start or post until I read another post in the Audacity Forum which allowed me to post.
Perhaps I don’t have permissions to post? Perhaps I should have research further before barging in so I humbly beg forgiveness and ask all to disregard or to have compassion and lend a hand if you have info that could solve my issue. Thanks for any direction and once again I am sorry and I will return to my closet of ignorance if no one can shed Light on my issue.

I truly am sorry for “barging” into this topic/thread

That’s OK. It’s forum housekeeping. We can deal with this.

Audacity ver 2.x.x

That’s not OK. We need the real Audacity version numbers. In addition to the regular Audacity product versions, we also have to deal with third party versions and they frequently scramble the numbers. So as of right this second, we have no idea which version you have.

On Windows it’s Help > About…I think. I’m on a Mac and it’s different.


Audacity version 2.1.0
It recorded via the microphone jack ok and on the playback it did not give the error “error opening sound device” until after I selected and tried different output devices that were listed. There were three devices recognized by Audacity which are the same as listed by Windows device manager although one was not plugged in (assume headphone jack). I manually sequenced thru each devices listed to see if any would work but no audio could be heard during playback. I did select Transport and enable playback in Audacity but this not make any difference even when I close Audacity and try to play CD using the Media Player. I returned to the original setting (default) in Audacity and starting getting above error. Windows sounds beeps etc work through the built in speakers but Windows Media Player and another will no longer output CDs ie no audio can be heard. All return above error of error opening sound device. System check via device manager says the devices are “working properly”. Guess I made the wrong choice in trying Audacity? I got a warning when trying to install on my Win ver 10 operating system something to the effect “this program may damage your computer” so I did not install and moved Audacity via a thumb drive to an older laptop.