recording - "no audio devices are installed

hi, first off. I hope im not cluttering this forum with my problem as im sure its been posted already.

when i hit the record button in audacity it says “error while opening sound device. please check the input device settings and the sample rate”

im using a custom built pc with windows 7 that i just bought this from someone i met that fixes computers, i inspected it to the best of my knowledge before i bought it as everything seemed (seems) fine. but for some reason audacity is not recognizing that i have a recording device installed.

now i have tried everything already, (all drivers are updated, i uninstalled and reinstalled, i tinkered with device manager. i right clicked the speaker icon on the bottom corner, etc…)

when i go in audacity to edit, preferences, the playback device is set to my speakers. but when i go to recording device, there is nothing there, nothing to choose from. it is just blank. but my speakers work fine.

i have this product made by line 6 called toneport ux1. it is a hardware device that plugs into my computer via usb 2.0. it allows me to plug my guitar into it ultimately through my computer so i can use my computer and the speakers as an amplifier. it works fine as it should. but for some reason audacity wont let me record anything because it appears there is no device that will allow me to record.

side note - my old computer worked fine. it listed the playback AND recording device under the options in audactity. it had something “Realtek” audio device, plus my toneport…so it had two devices listed, as opposed to this computer that only has the toneport listed. also i do not know what type of motherboard this pc has as it is custom built. but the sound device says “high definition audio device”, which is set as my default device but when i go to recording there is nothing there, blank.

ive also tried plugging the toneport device into all the different usb slots and got the same results.

does anyone know how to fix this?
thank you

Ensure that the toneport is connected and recognised by Windows before you open Audacity.
To check that the Toneport has been correctly recognised by Windows, look in the Windows Sound Control Panel and check that it is listed as a recording device and that it is enabled.

wow. ive done that what seems like a thousand times already and this time you suggested I do it; so I did it, and it worked. thank you